Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите мне пожалуйста с программой..(В паскале) Опишите процедуру поиска наибольшего и наименьшего элемента массива. С помощью этой процедуры составить

10-11 класс

программу, которая определяет совпадают ли наибольший и наименьший элементы двух массивов A[1..n], B[1..n].

Valeriyakochko 25 мая 2013 г., 10:33:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Поля27
25 мая 2013 г., 11:28:01 (10 лет назад)

program gt;
var n,i,max,max2,min,min2:integer;
a,b:array[1..100]of integer;
procedure proverka(a:array[1..100]of integer;var max,min:integer);
begin
max:=a[1];min:=a[1];
for i:=1 to n do
begin
if(a[i]>max)then max:=a[i];
if(a[i]<min)then min:=a[i];
end;
end;
begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
read(b[i]);
proverka(a,max,min);
proverka(b,max2,min2);
if  (max = max2) and (min = min2) then writeln('YES')else
writeln('NO');
end.

+ 0 -
Tambrey
02 июля 2016 г., 11:11:44 (7 лет назад)

1. FYI, diacritic was an adjective before it was a noun.2. Diacritical is used as an adjective in DIACRITICAL MASS. It seems a perfectly reasonable coinage for “lots of diacritical marks” (the phrase most people use for dic;8itias).I&#r217cm down with HYPERCRITICAL, but where’s the beef?

+ 0 -
Bubbi
03 июля 2016 г., 5:31:33 (7 лет назад)

Well madcaamia nuts, how about that.

+ 0 -
Vinnie
04 июля 2016 г., 15:02:41 (7 лет назад)

Wow, your post makes mine look feebel. More power to you!

Ответить

Другие вопросы из категории

Помогите, Пожалуйста, с программой Паскаль. Рассмотрим целочисленный массив А[1..N] при N <= 100.

Написать программу, которая вычисляет среднее арифметическое элементов с четными индексами и среднее арифметическое с нечетными индексами.
Ввод: Число N и элементы массива вводятся из Файла.
Вывод: В файл должны быть введены 2 вычисленных значения

с клавиатуры вводят слово.Составить программу ,которая: а)определяет количество символов в нём б)проверяет,не совпадают ли первая и

последняя буквы слова

в)выводт на экран первый,второй и последний символы

г)определяет,чётно или нечётно количество символов в нём

Читайте также

«Технология обработки числовой информации» Excel Вопрос 1. ЭТ – это 1)Прикладная программа, предназначенная

для обработки структурированных в виде таблицы данных

2)Прикладная программа для обработки кодовых таблиц

3)Устройство ПК, управляющее его ресурсами в процессе обработки табличных данных

4)Системная программа, управляющая обработкой табличных данных

Вопрос 2. ЭТ предназначена для

1)обработки числовых данных, представленных в виде таблиц

2)упорядоченного хранения и обработки значительных массивов данных

3)визуализации структурных связей между данными, представленными в виде таблиц

4)редактирования больших объемов информации

Вопрос 3. ЭТ представляет собой

1)совокупность пронумерованных столбцов и поименованных буквами латинского языка строк

2)совокупность пронумерованных строк и поименованных буквами латинского языка столбцов

3)совокупность пронумерованных строк и столбцов

4)совокупность строк и столбцов

Вопрос 4. Строки ЭТ

1)именуются пользователем произвольным образом

2)обозначаются буквами латинского языка

3)обозначаются буквами русского языка

4)нумеруются

Вопрос 5. Столбцы ЭТ

1)обозначаются буквами русского языка

2)нумеруются

3)обозначаются буквами латинского языка

4)именуются пользователем произвольным образом

Вопрос 6. Для пользователя ячейка ЭТ идентифицируется

1)адресом машинного слова ОП, отведенного под ячейку

2)специальным кодовым словом

3)путем последовательного указания имени столбца и номера строки, на пересечении которых располагается ячейка

4)именем, задаваемым пользователем

Вопрос 7. Вычислительные формулы в ячейках ЭТ записываются

1)в обычной математической записи

2)специальным образом с использованием встроенных функций и по правилам, принятым для записи выражений в языках программирования

3)по правилам, принятым исключительно для электронных таблиц

4)по правилам математики

Вопрос 8. Выражение 3 (А1+В1) : 5 (2В1-3А2), записанное в соответствии с правилами,

принятыми в математике, в ЭТ, имеет вид

1)3* (А1+В1)/(5*(2*В1-3*А2))

2)3(А1+В1)/5*(2В1-3А2)

3)3(А1+В1)/(5*(2В1-3А2))

4)3*(А1+В1)/5*(2*В1-3*А2)

Вопрос 9. Среди приведенных отыщите формулу для ЭТ

1)А3В8+12

2)А1=А3*В8+12

3)А3*В8+12

4)=А3*В8+12

Вопрос 10. Запись формулы в ЭТ не может включать в себя

1)знаки арифметических опраций

2)числовые выражения

3)имена ячеек

4)текст

Вопрос 11. При перемещении или копировании в ЭТ абсолютные ссылки

1)не изменяются

2)преобразуются вне зависимости от нового положения формулы

3)преобразуются в зависимости от нового положения формулы

4)преобразуются в зависимости от длины формулы

Вопрос 12. При перемещении или копировании в ЭТ относительные ссылки

1)преобразуются в зависимости от нового положения формулы

2)не изменяются

3)преобразуются вне зависимости от нового положения формулы

4)преобразуются в зависимости от длины формулы

Вопрос 13. Диапазон - это

1)совокупность клеток, образующих в таблице область прямоугольной формы

2)все ячейки одной строки

3)все ячейки одного столбца

4)множество допустимых значений

Вопрос 14. Активная ячейка - это ячейка

1)для записи формул

2)для записи чисел

3)для записи чисел, формул, текста

4)в которой выполяется ввод данных

Вопрос 15. Какая Формула будет получена при копировании в E4 формулы из Е2?

1)=А2*С4

2)=А2*$С$4

3)=$А$2*С4

4)=A4*C4

Вопрос 16. Какая Формула будет получена при копировании в E4 формулы из Е2?

1)=A2*5

2)=$A$2*4

3)=A2*$C$4

4)=$A$2*5

Вопрос 17. Какая Формула будет получена при копировании в E4 формулы из Е2?

1)=$А$2*$С$4

2)=A2*$C$2

3)=$А$2*С4

4)=A4*C4

Вопрос 18. Чему будет равно значение в ячейке С1, если в нее ввести формулу =А1+В1?

1)15

2)10

3)20

4)25

Вопрос 19. Чему будет равно значение в ячейке С1, если в нее ввести формулу

=СУММ(А1:В1)*2?

1)10

2)300

3)100

4)30

Вопрос 20. Сортировкой называют

1)процесс поиска наибольшего и наименьшего элементов массива

2)процесс частичного упорядочения некоторого множества

3)любой процесс перестановки

4)процесс линейного упорядочения некоторого множества

Помогите, Пожалуйста, с программой Паскаль. Рассмотрим целочисленный массив А[1..N] при N <= 100.

Написать программу, которая вычисляет среднее арифметическое элементов с четными индексами и среднее арифметическое с нечетными индексами.
Ввод: Число N и элементы массива вводятся из Файла.
Вывод: В файл должны быть введены 2 вычисленных значения

Помогите пожалуйста написать программу в паскале.

Составить программу перевода натурального числа из десятичной системы счисления в двоичную

10-11 класс информатика ответов нет
написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!



Вы находитесь на странице вопроса "Помогите мне пожалуйста с программой..(В паскале) Опишите процедуру поиска наибольшего и наименьшего элемента массива. С помощью этой процедуры составить", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.