Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите, Пожалуйста, с программой Паскаль. Рассмотрим целочисленный массив А[1..N] при N <= 100.

10-11 класс

Написать программу, которая вычисляет среднее арифметическое элементов с четными индексами и среднее арифметическое с нечетными индексами.
Ввод: Число N и элементы массива вводятся из Файла.
Вывод: В файл должны быть введены 2 вычисленных значения

катя202020 20 мая 2013 г., 20:30:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
SelinVitya
20 мая 2013 г., 22:05:58 (10 лет назад)

Программа:
const     n = 100;
type    mas = array[1..n] of byte;
var   input: text;   
output: text;   
a: mas;   
count : byte;   
i: byte;   
sum_1, sum_2 : integer;   
n_1, n_2 :byte;   
avrg_1, avrg_2 : real;
begin     
sum_1 := 0;     
sum_2 := 0;     
n_1 := 0;     
n_2 := 0;
assign(input,'in.txt');     
assign(output,'out.txt');     
reset(input);     
rewrite(output);
write('N : ');     
readln(count);         
for i:=1 to count do     
begin         
readln(input,a[i]);         
if i mod 2 = 1 then         
begin           
sum_1 := sum_1 + a[i];           
n_1 := n_1 + 1;         
end         
else
begin           
sum_2 := sum_2 + a[i];           
n_2 := n_2 + 1;         
end     
end;
avrg_1 := sum_1 / n_1;     
avrg_2 := sum_2 / n_2;
writeln(output,avrg_1);     
writeln(output,avrg_2);
close(input);     
close(output);
end.

Ответить

Другие вопросы из категории

с клавиатуры вводят слово.Составить программу ,которая: а)определяет количество символов в нём б)проверяет,не совпадают ли первая и

последняя буквы слова

в)выводт на экран первый,второй и последний символы

г)определяет,чётно или нечётно количество символов в нём

Читайте также

Помогите пожалуйста составить программу в Паскале: Дан

целочисленный массив из N элементов.
Вывести на экран сумму всех четных чисел
в этом массиве.

помогите пожалуйста нужна программа Паскаль вот задача (При каждом переходе через волшебный мост мужик, имеющий b рублей, удваивает эту сумму за счет

капитала черта (а рублей), стерегущего этот мост, после чего он должен уплатить черту дань в размере с рублей. Процесс этот продолжается до полного разорения одного из участников.Сколько будет совершено переходов моста?). вот блок схема пожалуйста сроочноо



Вы находитесь на странице вопроса "Помогите, Пожалуйста, с программой Паскаль. Рассмотрим целочисленный массив А[1..N] при N <= 100.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.