Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан массив Array[1..100]

10-11 класс

С помощью цикла присвоить, каждому элементу массива значение равное номер элемента умноженный на 3. например для массива А значение элемента А[1]=2, A[2]=6 A[3]=9 и т.д. В конце программа должна выводить на экран сумму всех элементов массива.

Danil1443 18 авг. 2013 г., 14:06:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
61803
18 авг. 2013 г., 16:53:34 (10 лет назад)

var A :array[1..100] of integer;
var i, S :integer;
begin
for i:=1 to 100 do A[i]:=i*3;
S:=0;
for i:=1 to 100 do S:=S+A[i];
Writeln('сумма элементов массива= ',s);
end.

или без лишнего цикла можно так
var A :array[1..100] of integer;
var i, S :integer;
begin
for i:=1 to 100 do
   begin
         A[i]:=i*3;
        S:=S+A[i];
  end;
Writeln('сумма элементов массива= ',s);
end.

Ответить

Другие вопросы из категории

Выполнить действие и результат проверить в десятичной системе счисления.

1101(2)*101(2)
Нужно срочно, помогите!

Элемент матрицы называется локальным минимумом, если

он строго меньше всех имеющихся у него соседей. Подсчитать количество локальных
минимумов заданной матрицы размером 10 на 10.

Найти сумму модулей элементов, расположенных выше
главной диагонали.
на языке С

Помогите пожалуйста!!!

Составить блок-схему и написать
на VBA
функцию, вычисляющую
для одномерного массива

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

Var a:array [1..100,1..100] of real;

b:array [1..100,1..100] of real;
i,m,n,c:integer;
begin
readln(n);
readln(c);
for i:=1 to n do
for m:=1 to c do readln(a[i,m]);
for i:=1 to n do
for m:=1 to c do
b[i,m]:=a[i,m]/8;
for i:=1 to n do
for m:=1 to c do writeln(b[i,m]);
end.
можете написать обозначение каждого символа

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .



Вы находитесь на странице вопроса "Дан массив Array[1..100]", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.