Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Заполните массив из 10 целых чисел через генератор случайных чисел в диапазоне от 3 до 10 и найти кол-во элементов массива значение

10-11 класс

которых равно 4 (в паскаль)

FREE PASCAL

Ladyabesadze 09 марта 2015 г., 23:42:06 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
09наталья1985
10 марта 2015 г., 1:59:51 (9 лет назад)

var i,k : integer;
 a: array[1..10] of integer;
Begin
  for i := 1 to 10 do begin
    a[i] := random(7) + 3;
    if a[i] = 4 then k:= k + 1;
  end;
  writeln(k);
End.

+ 0 -
Даша1111111111111111
10 марта 2015 г., 4:36:22 (9 лет назад)

Простите, не могу помочь =(

+ 0 -
Amir45
10 марта 2015 г., 6:02:19 (9 лет назад)

Если как-то может пригодиться, на паскале абц:
var a:array[1..10] of integer;
i,k:integer;
begin
randomize;
for i:=1 to 10 do begin a[i]:=random(8)+3; write(a[i],' '); if a[i]=4 then k:=k+1; end;
writeln;
write(k);
end.

+ 0 -
Ansimovru
10 марта 2015 г., 8:30:06 (9 лет назад)

только первое число тут большим выходит всегда, а так прога отличная)))

+ 0 -
Bboyfidjet
10 марта 2015 г., 11:25:01 (9 лет назад)

я когда-то вот так писал(тут для любого числа, но не выводит само содержание массива, хотя это вообще легко написать, кстати тоже АБС

+ 0 -
Kgfgjddh
10 марта 2015 г., 13:57:25 (9 лет назад)

uses crt;
var i,kol:integer;
x:real;
N:array [1..100] of real;
z:char; label 1;
begin
1:for i:=1 to 100 do
N[i]:=random(100);
write('Введите искомое число: ');
read(x);
for i:=1 to 100 do
if N[i]=x then Inc(kol);
writeln('Число ',x,' встречается ',kol,' раз.');
writeln('Ещё??? y-да, n-нет.');
read(z);
if (z='y') or (z='Y') then goto 1
else
read;
end.

Ответить

Другие вопросы из категории

Определить сколько раз исполнится тело цикла и чему будет равно значение переменной 1) S:=18 for i:=5 to 3 do S:=S * 2; S:=S+2;

2) S:=15; i:=5. while i<7 do begin i:=i+1 S:=S+S; end

3) S:= -6; i:=4

while i>8 do i:=i+1; S:=S * 0 .

ПОМОГИТЕ ПОЖАЛУЙСТА

1."Вы выходите на следующей остановке?" -
спросили человека в автобусе.
"Нет", - ответил он. Сколько информации содержит ответ?
2. Какой объем информации содержит сообщение,
уменьшающее неопределенность знаний в 4 раза?


3. Вы подошли к светофору, когда горел желтый свет.
После этого загорелся зеленый. Какое количество информации Вы при этом
получили?


4. Группа школьников пришла в бассейн, в котором 4
дорожки для плавания. Тренер сообщил, что группа будет плавать на дорожке
№ 3. Сколько информации получили школьники из этого сообщения?


5. В корзине 8 шаров. Все шары разного цвета. Сколько
информации несет сообщение о том, что из корзины д7остали красный шар?


6.В библиотеке 16 стеллажей. На каждом стеллаже по 8
полок. Библиотекарь сказала Оле,
что интересующая ее книга, находится на 5 стеллаже, на 3й сверху полке сверху.
Какое количество информации получила Оля?


7. При угадывании целого числа в диапазоне от 1 до N было получено 4 бита
информации. Чему равно N?
8. Была получена телеграмма :"Встречайте, вагон 7". Известно, что в составе поезда 16 вагонов. Какое количество информации было получено
9.при угадывании целого числа в некотором диапазоне было получено 6 бит информации. Сколько чисел содержит этот диапазон?
10. сообщение о том, что ваш друг живет на 10м этаже, несет 4 бита информации. сколько этажей в доме?
сообщение о том, что петя живет во 2м подъезде, несет 3 бита информации. сколько подъездов в доме
11. в коробке лежат 7 разноцветных карандашей. какое количество информации содержит в себе сообщение , что из коробки достали красный карандаш?
12. какое количество информации несет сообщение:"встреча назначена на сентябрь"
13. какое количество информации несет сообщение о том, что встреча назначена на 15 число?
14. какое количество информации несет сообщение о том, что встреча назначена на 23 октября в 15:00
15. какое количество информации несет сообщение о том, что нужная вам программа находится на одной из восьми дискет
16. какое количество информации получит 2й игрок при игре в крестики-нолики на поле 8x8, после первого хода первого игрока, играющего крестиками?
17. в рулетке общее количество лунок равно 128. какое количество информации мы получаем в зрительном сообщении об остановке шарика в одной из лунок?
18. происходит выбор одной карты из колоды 32 карты. какое количество информации мы получаем в зрительном сообщении о выборе определенной карты?













Читайте также

составить программу 1)найти сумму всех элементов массива (1до10) random. 2)сформировать массив из положительных и отрицательных элементов

от -10 до 30.найти кол-во положит и отриц элементов.найти сумму положит и произведение отриц.

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.



Вы находитесь на странице вопроса "Заполните массив из 10 целых чисел через генератор случайных чисел в диапазоне от 3 до 10 и найти кол-во элементов массива значение", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.