Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано 11 чисел. Найти суммы

5-9 класс

чисел кратных 3 и некратных 9.

Floksiniya 13 окт. 2013 г., 23:45:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
206668
14 окт. 2013 г., 2:39:32 (10 лет назад)

Program Pr1

var

a: array [1..11] of integer;

i,sum:integer;

begin

sum:=0;

for i:=1 to 11 do

begin

readln(a[i])

if  (a[i] mod 3=0) then 

sum:=sum+a[i];

writeln(sum);

sum:=0;

if  (a[i] mod 9<>0) then

sum:=sum+a[i];

writeln(sum);

end.

+ 0 -
Buryy04
14 окт. 2013 г., 3:28:16 (10 лет назад)

Program Pr1;

var a:array [1..11] of integer;

SumCr,SumNeCr,i:integer;

Begin

SumCr:=0;

SumNeCr:=0;

Randomize;

For i:=1 to 11 do

a[i]:=random(100);

Writeln (a[i],'  ');

Readln;

Begin

For i:=1 to 11 do

If a[i] mod 3 = 0 then SumCr:=SumCr+a[i];

Writeln ('Сумма чисел кратных 3 равна',CumCr);

Readln;

End;

Begin

For I:=1 to 11 do

If a[i] mod 9 <> 0 then SumNeCr:=SumNeCr+a[i];

Writeln ('Сумма чисел не кратных 9 равна',SumNeCr);

Readln;

End;

End.

Ответить

Другие вопросы из категории

№3. Отметьте истинные высказывания.

1. объект, который используется в качестве "заместителя", представителя другого объекта с определенной целью, назв. моделью.
2. модель обладает всеми признаками объекта-оригинала.
3. модель имеет существенные признаки объекта-оригинала.
4. модель содержит меньше информации, чем объект-оригинал.
5. модель содержит больше информации, чем объект-оригинал.
6. модель содержит столько же информации, что и объект-оригинал.
7. можно создавать и использовать разные модели объекта.
8. можно создавать и использовать единственную модель объекта.
9. можно создавать и использовать только натурные модели объекта.

Помогите)Световое табло состоит из лампочек, каждая из которых может находиться в двух состояниях : включено и выключено. Какое наименьшее

количество лампочек должно находиться на табло, чтобы с его помощью можно было передавать 15 различных сигналов

Напишите программу которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число кратное 6. Кол-во чисел не превышает 100. Введённые числа не привышают 300. Программа должна ввести одно число - сумму чисел кратных 6

пожалуйста помогите срочно нужно

подберите вопросы к каждому слову как типа красворда

Читайте также

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

1.С клавиатуры вводится 3 числа. Найти сумму только из положительных чисел.

(Тема:Программирование ветвлящихся и цепленных алгоритмов)
2.Дано двухзначное число,найти сумму и произведение его чисел.
(2-ая задача решается с div и mod)
(Тема:Программирование ветвлящихся и цепленных алгоритмов )

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!



Вы находитесь на странице вопроса "Дано 11 чисел. Найти суммы", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.