Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Подсчитать колво цифр(чисел) не отрицательных среди N-произвольных и вывести на экран

5-9 класс

Krasolya 11 июля 2014 г., 19:31:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Касси
11 июля 2014 г., 21:36:55 (9 лет назад)

var a:array[1..100] of integer;

      i,n,k:integer;

begin

k:=1;

read(n);//Вводите количество самих элементов

for i:=1 to n do begin//Ввод самих элементов

read(a[i]);if a[i]>=0 then k:=k+1;//Подсчет элементов >0

end;

writeln('Количество не отрицательных элементов=',k);//Вывод

readln;

end.

Ответить

Другие вопросы из категории

Для шифрования сообщения был выбран следующий метод: сдвиг каждой из 33 букв русского алфавита на 3 буквы вперед, при этом алфавит считается циклическим, т

о есть буква "я" переходит в букву "г".
Расшифруйте слова и выберите те из них, которые обозначают устройства, входящие в состав персонального компьютера.
1)УФЕЪИХХТФ
2)МСЦИЖФДП
3)УПДЦД
4)ЗМХО
5)УФТМЁТЗСДГ
6)УТПИ

информационное сообщение на русском языке, первоначально записанное в 8-битовом коде windows, было перекодировано в 16-битовую кодировку unicod. В

результате информационный объем сообщения стал равен 2 Мбайта. Найдите кол-во символов в сообщении

Читайте также

в массиве действительных чисел с от 1 до 11 посчитать сумму отрицательных элементов, произведение положительных и вывести на экран номера нулевых элемен

тов.
ПОМОГИТЕ ПОЖАЛУЙСТА!!!с помощью паскаля, а числа задавать можно любым способом.

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных

данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

1.Найти произведение всех целых чисел от а до 100 (а<100) кратных 17,но не кратных 2 2.Вычислите: 98+96+94+92+90+88+,,,,,+6+4+2

3.Определить и вывести на экран количество трехзначных чисел,которые делятся без остатка на 5 и 21 одновременно.

4.спортсмен пробежал в 1-ый день тренеровки расстояние 10 км. В каждый следующий день он робегал на 3 км больше ,чем в предыдущий. Определить Суммарное расстояние.

5. в Пионерском лагере n отрядов с различным количеством детей. Сколько всего детей в пионерском лагере?



Вы находитесь на странице вопроса "Подсчитать колво цифр(чисел) не отрицательных среди N-произвольных и вывести на экран", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.