Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль) помогите пожалуйста)

10-11 класс

Напишите программу вычисления среднего геометрического модулей двух введенных с клавиатуры чисел. Программа должна использовать цикл while do. Условия выхода их цикла-значение числа, равное 999.

JSwift 30 авг. 2016 г., 20:33:25 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nilpts
30 авг. 2016 г., 22:56:23 (7 лет назад)

Program Zadacha;
Var a, b, i: Integer;
c: Real;
Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
c := Sqrt(Abs(a) * Abs(b));
i := 0;
While i < 999 Do
i := i + 1;
WriteLn('Результат: ', c:5:2);
ReadLn;
End.

+ 0 -
Erhrthrthr
31 авг. 2016 г., 0:20:44 (7 лет назад)

var a,b,sg: real;
begin
readln(a);
readln(b);

a:=abs(a); b:= abs(b);
sg:= sqrt(a*b);

writeln(sg);
end.

Вот программа вычисления средней геометрической. Но про цикл не понял...

+ 0 -
Efremenko2001
31 авг. 2016 г., 1:00:34 (7 лет назад)

Для чего здесь вообще цикл?

+ 0 -
Dima1000000
31 авг. 2016 г., 2:38:15 (7 лет назад)

я не знаю, это самые азы Паскаля типа.

Ответить

Другие вопросы из категории

НУЖНО РЕШЕНИЕ В терминологии сетей TCP/IP маской сети называется двоичное число, определяющее, какая часть IP-адреса узла сети

относится к адресу сети, а какая – к адресу самого узла в этой сети. Обычно маска записывается по тем же правилам, что и IP-адрес. Адрес сети получается в результате применения поразрядно конъюнкции к заданному IP-адресу узла и маске. По заданным IP-адресу узла и маске определите адрес сети. IP-адрес узла : 224.120.249.18 Маска: 225.225.240.0 При записи ответа выберите из приведённых в таблице чисел четыре элемента IP-адреса сети и запишите в нужном порядке соответствующие им буквы, без использования точек.

Читайте также

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите пожалуйста :(((

Даны шесть монет, из которых одна фальшивая. Фальшивая монета отличается от настоящей монеты весом, причем она либо немного тяжелее, либо немного легче. Имея рычажные весы, определить ложную монету не более чем за три взвешивания.
Это в паскале надо)
Пожалуйста!!!!))))



Вы находитесь на странице вопроса "Паскаль) помогите пожалуйста)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.