Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задача по Turbo PascalЗаполнить massive A: array; [ 1..15 ] of char; Символами- буквами латинского алфавита под a до 15

10-11 класс

латинскме буквы.

Распечатать на экран данный массив в обратном порядке.

Inu 21 нояб. 2013 г., 17:45:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kasenova595
21 нояб. 2013 г., 19:04:32 (10 лет назад)

Program pr;
uses crt;

Var i:integer;
       a:array[1..15] of char;

Begin
Writeln('Введите массив');

for i:=1 to 15 do
readln(a[i]);

for i:=15 downto 1
Writeln(a[i]);

readln;
end.

Ответить

Другие вопросы из категории

Скорее всего, ваши компьютеры уже не работают с дискетами - гибкими

магнитными дисками, помещёнными в защитный пластиковый корпус. Но
практически в каждой компьютерной программе, предназначенной для
создания информации того или иного вида, есть команды, графическим
образом которых является дискета. Какие это команды?

Упростить логическое выражение

(AvB)->(BvC)

Читайте также

Помогите решить задачи по паскалю:

1. модифицируйте предыдущий пример, так чтобы программа определяла максимальный и минимальный элемент массива
2. Напишите программу, которая бы определяла среднее арифметическое значение элементов массива (вещественная величина типа real)
Начало:
var a: array[1..10] of integer;
i: integer;
begin
а как дальше?

Предыдущий пример:
var a: array[1..10] of integer;
i: integer;
begin
randomize;
for i:=1 to 10 do
begina[i]:=random(40)-20;
end;
for i:=1write(a[i]:4);
end.

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.

program klass; type ocenki=record name:string[15]; marks: array [1..5] of integer; end; var a,k,i:integer;

c:array [1..5] of ocenki;

begin k:=0;

For i:=1 to 5 do

With c[i] do

begin

write('vvedite name'); readln(name);

write('vvedine marks');

for i:=1 to 5 do read(marks[i]);

a:=i;

if c[a].marks < 2 (вот здесь выдает что операнды имеют неприводимые типы) then k:=k+1; writeln(k);

end;

end.

(Подскажите пожалуйста где допустила ошибку)

Почему не работает программа по нахождению полиндрома через массив?? Не понимаю?? const

n=5;
var
a: array[1..n] of char;
i,c: integer;
begin

for i:=1 to n do
read (a[i]) ;
readln;

c:=0;
for i:=1 to n div 2 do
if a[i]<>a[n-1-i] then c:=1;
if c=0 then writeln('polindrom')
else writeln('no');
readln;

По горизонтали: 1. Минимальный элементом электронной таблицы. 2. Объект электронной таблицы, предназначенный для

представления данных в графическом виде.

4. Специальное средство для создания формулы.

5. С этого знака начинается формула.

6. Группа смежных ячеек, образующая прямоугольную область.

8. Область, обозначенная целыми числами.

По вертикали:

3. Область, обозначенная буквами латинского алфавита.

7. Операция, используемая для автоматического заполнения числовыми и текстовыми данными.

P.S срочно нужно помогите пож-та :(



Вы находитесь на странице вопроса "Задача по Turbo PascalЗаполнить massive A: array; [ 1..15 ] of char; Символами- буквами латинского алфавита под a до 15", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.