Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите решить задачи по паскалю:

10-11 класс

1. модифицируйте предыдущий пример, так чтобы программа определяла максимальный и минимальный элемент массива
2. Напишите программу, которая бы определяла среднее арифметическое значение элементов массива (вещественная величина типа real)
Начало:
var a: array[1..10] of integer;
i: integer;
begin
а как дальше?

Предыдущий пример:
var a: array[1..10] of integer;
i: integer;
begin
randomize;
for i:=1 to 10 do
begina[i]:=random(40)-20;
end;
for i:=1write(a[i]:4);
end.

Yanashelkovkin 11 янв. 2015 г., 1:57:25 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Надин123
11 янв. 2015 г., 2:57:59 (9 лет назад)

const
  n = 10;

var
  a: array[1..n] of integer;
  i, k, min, max: integer;

begin
  randomize;
  min := 100; max := -100;
  Writeln('исходный массив');
  for i := 1 to n do
  begin
    k := random(40) - 20;
    a[i] := n;
    if max < k then max := k
    else if min > k then min := k;
    Write(k, ' ')
  end;
  Writeln;
  Writeln('min=', min, ', max=', max)
end.

Тестовое решение:
исходный массив
-8 3 19 -14 19 13 -17 -2 8 8
min=-17, max=19

---------------------------------------------------------
const
  n = 10;

var
  a: array[1..n] of integer;
  i, k, s: integer;

begin
  randomize;
  s := 0;
  Writeln('исходный массив');
  for i := 1 to n do
  begin
    k := random(40) - 20;
    a[i] := n; s := s + k;
    Write(k, ' ')
  end;
  Writeln;
  Writeln('Среднее арифметическое равно ', s / k)
end.

Тестовое решение:
исходный массив
19 11 -1 1 -4 -6 -2 18 3 8
Среднее арифметическое равно 5.875





+ 0 -
Zikov2012Fighterpro
11 янв. 2015 г., 4:31:48 (9 лет назад)

Задание при этом осталось неполным, следовательно, оно будет удалено модераторами... Исправляйте ИСХОДНЫЙ вопрос.

+ 0 -
Sashaba42
11 янв. 2015 г., 7:29:48 (9 лет назад)

Никто не знает ответа?(

+ 0 -
Fdfdfdfkuh
11 янв. 2015 г., 9:01:45 (9 лет назад)

Просто надо время, чтобы его написать...

+ 0 -
Alesha2000ru
11 янв. 2015 г., 10:23:38 (9 лет назад)

хорошо, я подожду)

+ 0 -
MissKissAmir
11 янв. 2015 г., 11:38:25 (9 лет назад)

Вы написали что подождете после того, как был дан ответ? ))

Ответить

Другие вопросы из категории

Для какого из указанных

значений X истинно высказывание

¬ ((X>2) → (X>3))?

1) 1 2) 2
3) 3

Что из перечисленного нельзя отнести к недостаткам искусственных нейронных сетей: а) сравнительная дороговизна аппаратной реализации; б) трудность

тиражирования накопленных знаний; в) для больших сетей невозможность заранее даже приблизительно оценить время обучения сети г) создание новых знаний внутри сети в процессе переработки входных данных.

Требовалось написать программу, которая вводит с кла­виатуры

координаты точки на плоскости (х,у — действи­тельные числа) и определяет
принадлежность точки за­штрихованной области, включая ее границы. Програм­мист
торопился и написал программу неправильно.

Помогите, пожалуйста, с информатикой, а то не понимаю(

Определите какое число будет напечатано в результате выполнения следующего алгоритма
dim a,b,t,M,R as integer
Function F( x as integer) as integer
begin F=19-19*(x-1)*(x-1)
end
begin
a=1- b=20
M=a R=F(a)
for t=a to b
if F(t)>R then
M=t
R=F(t)
end
next
print m
End

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.



Вы находитесь на странице вопроса "Помогите решить задачи по паскалю:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.