Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

В числовой последовательности из N произвольных целых чисел определить количество пар соседних элементов одинаковых по модулю, но разных по

10-11 класс

знаку.

KVNshik 01 окт. 2016 г., 23:01:48 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Stoessel1
02 окт. 2016 г., 0:16:04 (7 лет назад)

uses crt;
const n=10;
var a:array [1..n] of integer;
i,k: integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(100);
writeln(a[i]);
end;
writeln;
for i:=1 to n-1 do
begin
if abs(a[i])=abs(a[i+1])
then
begin
if ((a[i]>0) and (a[i+1]<0)) or ((a[i]<0) and (a[i+1]>0))
then
inc(k);
end;
end;
writeln(k);
end.

Ответить

Другие вопросы из категории

Срочно!!!!!!!!!Написать программу в паскале (и желательно блок схему) для задачи:

Ввести 10 чисел, и вывести на экран наименьшее.

Дан массив целых чисел (n=10), заполненный случайными числами из промежутка [-40,30]. 1. удалить из него все элементы, которые состоят из одинаковых

цифр(включая однозначные числа). 2. вставить число k перед всеми элементами, в которые оканчиваются на 7(k вводить с клавиатуры)

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

Вводится последовательность из N положительных целых чисел. Найти

наименьшее число среди чётных элементов последовательности.

Помогите

Вводится последовательность из N положительных целых чисел. Найтинаименьшее число среди чётных элементов последовательности.
n=1-100
Lazarus



Вы находитесь на странице вопроса "В числовой последовательности из N произвольных целых чисел определить количество пар соседних элементов одинаковых по модулю, но разных по", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.