Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Паскаль

10-11 класс

1.Найти все двухзначные числа,такие,что если к сумме цифр числа прибавить квадрат этой суммы,то получится это число.
2.Найти четырехзначное число,которое при делении на 133 дает в остатке 125,а при делении на 134 остаток 111.

2009kris18 28 авг. 2014 г., 3:03:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
бровкина
28 авг. 2014 г., 5:56:52 (9 лет назад)

program gt;
var i,p,s,q:integer;
begin
for i:=10 to 99 do
begin
p:=i;
s:=0;
while p>0 do
begin
q:=p mod 10;
p:=p div 10;
s:=s+q;
end;
if(s+s*s=i)then writeln(i);
end;
end.
2)
program gt;
var i:integer;
begin
for i:=1000 to 9999 do
begin
if(i mod 133=125)and(i mod 134=111)then writeln(i);
end;
end.

Ответить

Другие вопросы из категории

решение - объяснение - просто ответы есть (не пишите) Сколько существует различных пар натуральных чисел, таких что: 1. Оба

числа, записанные в пятеричной системе счисления, имеют ровно по три значащих разряда. 2. Сумма этих чисел, записанная в пятеричной системе счисления, содержит только цифры «1». Пары чисел, отличающиеся только порядком следования чисел в паре, считаются одинаковыми. В ответе укажите целое число.

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "Паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.