Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

напишите программку в Паскале через массив.

5-9 класс

Введите последовательность из n целых чисел. Найдите наибольшее из отрицательных чисел.

Солнышко1234 08 сент. 2016 г., 7:26:19 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Олеся36
08 сент. 2016 г., 9:12:48 (7 лет назад)

const n = 5; //задаем число n ( вместо 5 подставить свое число)
var
max,i: integer;
a: array [1..n] of integer;
begin
max:= 0; 
for i:=1 to n do 
 begin 
readln(a[i]); 
if a[i] < 0 then max := a[i] 
end; 
for i:=1 to n do  
 if (a[i] < 0) and (a[i] > max ) 
 then max := a[i]; 
writeln(max);
end.

Ответить

Другие вопросы из категории

Помогите

ФОТО
Любое задание прошу

Пожалуйста помогите!!!

по способу восприятия человеком различают следующие виды информации:
а)текстовую, числовую, графическую, табличную и пр.
б)научную, социальную, политическую, экономическую, религиозную и пр.
в)обыденную, производственную, техническую, управленческую
г)визуальную, аудиальную, тактильную, обонятельную, вкусовую

Срочно, решите задачу, пожалуйста.

Вывести на экран массив из 10 случайных чисел и найти сумму значений элементов массива.

Читайте также

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

РЕШИТЕ ХОТЬ ЧТО-НИБУДЬ!!!:з 1.Линейные программы Напишите программу на ШАЯ.Вычислите значения следующих выражений: f=t*t/2+t

2.Условный оператор(ветвление)

Нарисуйте блок-схему.Дано два числа.Верно ли, что он равны?

3.Циклы

Напишите программу на Паскале. Выведите на экран табицу умножения на 4 в виде 1+4=4,2+4=8,....9*4=36.

4.Одномерные массивы

Напишите программу на Паскале.Подсчитайте количество максимальных элементов массива А [1..12].

5.Двумерные массивы

Напишите программу на Паскале. создать массив случайны чисел В[1..6,1..6].Все элементы массива, расположенные выше главной диагонали сделать равными О.Вывести исходный и исправленный массивы.

Нужно сделать программу в Паскале через тип integer. Задача: Составить программу, определяющию

массу кирпича. P=1400 кг/м3, V=25*12*6.5

Формула для нахождения массы: m= V*P

V - объём

m - масса

P - плотность

Решить данную задачу в Паскале через тип integer. Задача: Известна масса тела в

килограммах. Определить сколько целых тонн содержится в данном числе.

Просьба: если вы не умеете составлять программу, то ничего не пишите.

НАПИШИТЕ ПРОГРАММУ В ПАСКАЛЕ, СРОЧНО !!

написать программу, которая вычисляет среднее арифметическое ненулевых элементов массива M[1..100], элементы которого вычисляются по формуле M[i]=sin(i)*cos(i)

и прошу не используйте интернет, а напишите сами по возможности.



Вы находитесь на странице вопроса "напишите программку в Паскале через массив.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.