Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.

5-9 класс

Или

составьте программу, которая определяет на сколько в строке S слов, начинающихся на главную букву больше, чем в строке T

надо решить одну из них

091077595 13 апр. 2013 г., 9:09:03 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Arishka7777
13 апр. 2013 г., 12:02:49 (11 лет назад)

Первая.
uses
crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
while i<length(s) do
begin
if (s[i+1]=' ') and((s[i]='а') or (s[i]='е') or (s[i]='ё') or (s[i]='и') or (s[i]='о') or (s[i]='у') or (s[i]='ы') or (s[i]='э') or (s[i]='ю') or (s[i]='я')) then
begin
s:=copy(s,1,i)+'ОБА'+copy(s,i+1,length(s));
end;
i:=i+1;
end;
case s[length(s)] of 'а','е','ё','и','о','у','ы','э','ю','я':
s:=s+'ОБА';
end;
writeln(s);
end.

Ответить

Другие вопросы из категории

трехзначное десятичное число оканчивается цифрой 3. если эту цифру переместить на первое слева место в числе,то есть с нее будет начинаться запись нового

числа ,то это новое число будет на единицу больше утроенного исходного числа .найдите исходное число

Задача, паскаль АВС в искусственный водоем запустили 100 000 рыб. ежегодно из водоема забирают 12% рыб. естественный прирост сост. 20%. какое количество

рыб будет в водоеме через 8 лет? через сколько лет в водоеме будет 300 000 рыб, если начиная с пятого года из водоема стали ежегодно забирать ещё 5000 рыб?

Помогите!

Очень нужно

Читайте также

1)Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.

2)Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

1.Составить программу, которая определяет номера позиций символа","

2. Составить программу, которая позволяет заменить все гласные символом "*"

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.




Вы находитесь на странице вопроса "составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.