Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите очень срочно! 315. По данному натуральному n вычислите сумму 1^2 + 2^2+...+n^2. Вводится единственное число n. Необходимо вывести вычисленную

5-9 класс

сумму. 346.Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел. 347.Вводится число N, а затем N чисел. Выведите YES, если среди введенных чисел есть хотя бы один нуль, или NO в противном случае.

Chkj 06 нояб. 2014 г., 7:11:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Melinadz
06 нояб. 2014 г., 9:46:25 (9 лет назад)

Буду по порядку добавлять.

1)

uses crt;
var n,s,i:integer;
begin
clrscr;
write('n=');
readln(n);
s:=0;
for i:=1 to n do
s:=s+sqr(i);
write('s=',s);
end.

2)

uses crt;
var a:array [1..100] of real;
n,i,p,o,l:integer;
begin
clrscr;
write('n=');
readln(n);
write('a[n]:');
for i:=1 to n do
begin
readln(a[n]);
if a[n]>0 then p:=p+1;
if a[n]<0 then o:=o+1;
if a[n]=0 then l:=l+1;
end;
writeln(l,p,o);
end.

3)

uses crt;
var a:array [1..100] of real; i,n:integer;
begin
clrscr;
write('n=');
readln(n);
write('a[n]:');
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if (a[i]=0) then writeln('YES')
else writeln('NO');
end.

Ответить

Другие вопросы из категории

помогите пожалуйста!

спасибо

Эля решила сварить клубничноеЭля решила сварить клубничное варенье. Для этого необходимо взвесить ягоды. У Эли было 4 электронных весов, один из

которых были сломаны. Все весы показывали вес в различных системах счисления. Эля взвесила одну ягодку на всех весах поочередно и определила, какие именно весы сломаны. Известно, что первые весы показали вес 11011"2" (число которые в кавычках, надо писать в нижнем углу), вторые-200"3", третьи - 33"8", четвертые - 102"5". Сломаны весы под номером...
А) 1
Б) 2
В) 3
Г) 4

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА С ИНФОРМАТИКОЙ,НУЖНО ОЧЕНЬ СРОЧНО,: (решение задач с параметром,язык PASCAL) №1)дано натуральное n, вычислить:

а) -2/1! +3/2! -...+ (-1)^n *(n+1)/n! (n после единицы это степень)

б) 1!/1+ 2!/ (1+1/2) +....+ n!/ (1+1/2+...+1/n)

№2) дано натуральное n, действительное х, вычислить:

а) x^1 / 1! + x^2 /2+...+ x^n / n!

б)(1/2 - cosx)(2/3-(cos^2)*x)).....( n/(n+1) - (cos^n)* x))

Помогите написать программу которая по данному натуральному числу от 1 до 2 (номеру месяца) выдает все приходящихся на этот месяц праздничные

дни(например, если введено число 1, то; 1 января - новый год , 7 января - Рождество).

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!



Вы находитесь на странице вопроса "Помогите очень срочно! 315. По данному натуральному n вычислите сумму 1^2 + 2^2+...+n^2. Вводится единственное число n. Необходимо вывести вычисленную", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.