Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан целочисленный массив из 31 элемента, в котором записаны значения температуры воздуха в марте. Элементы массива могут принимать значения от (–20) до

5-9 класс

20. Опишите на русском языке или на одном из языков программирования алгоритм, который подсчитывает и выводит среднюю температуру по всем дням, когда была оттепель (температура поднималась выше нуля). Гарантируется, что хотя бы один день в марте была оттепель.

Skasap 21 янв. 2017 г., 3:15:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sisoevadascha2
21 янв. 2017 г., 4:15:52 (7 лет назад)

#include <stdio.h>
#include <conio.h>
#include <math.h>

int main(){
    signed short int t[31];
    float  srt=0;
    int kolt=0, n;
    for (n=0; n<31; n++){
        t[n]=rand()%20; //заполнение случайными числами от -20 до 20
    }
    for (n=0; n<31; n++){
        if(t[n]>0){
            srt=srt+t[n]; //сумма значений темп выше 0
            kolt=kolt+1; //кол-во темп выше нуля
        }
    }
    printf("\n %f \n",srt/kolt); //вывод ср темп сумма/кол-во
    return 0;
}

Ответить

Другие вопросы из категории

Для исполнитель кулинар предназначен для обжаривания лепёшек. лепёшка считается готовой, если каждая её сторона жарилась 1 минуту. команда действие

поместить1 поместить на сковороду 1 лепёшку поместить2 поместить на сковороду 2 лепёшки перевернуть1 перевернуть 1 лепёшку перевернуть2 перевернуть 2 лепёшки убрать1 убрать со сковороды 1 лепёшку убрать2 убрать со сковороды 2 лепёшки ждать ждать 1 минуту для исполнителя кулинар составьте алгоритм приготовления 5 лепёшек за 5 минут

Ребятки, снова прошу помощи!))) Условие: Составьте блок-схему и программу на языке VBA, которая вычисляет частное от деления двух чисел. Программа должна

проверять правильность введенных пользователем данных и, если они неверные (делитель равен нулю), выдавать сообщение об ошибке.
Я совсем не дружу с бейсиком(( Помогите пожалуйста! :)

помогите решить СРОЧНо!!!
что может означать запись : 18-15

с точки зрения: продавца, машиниста электропоезда?

Читайте также

помогите плиз)

Дан целочисленный массив из 31 элемента, в котором записаны значения температуры воздуха в марте. Элементы массива могут принимать значения от (-20) до 20. Опишите на русском языке и на языке Паскаля алгоритм, который подсчитывает и выводит среднюю температуру почетным дням месяца.

Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 160 до 200 ­– рост учащихся выпускного класса. В баскетбольную команду бе

рут тех, чей рост не менее 180 см. Опишите на русском языке или на одном из языков программирования алгоритм, который подсчитывает и выводит минимальный рост игрока баскетбольной команды. Гарантируется, что хотя бы один ученик играет в баскетбольной команде.Нужно паскаль

Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 0 до 100 – баллы, полученные на ЕГЭ. Опишите на русском языке или

на одном из языков программирования алгоритм, который подсчитывает и выводит средний балл учащихся, сдавших экзамен (получивших оценку более 20 баллов). Гарантируется, что хотя бы один ученик в классе успешно сдал экзамен.

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

Дан целочисленный массив из 20 элементов. Элементы массива принимают значения от 0 до 10000 включительно. Написать программу, позволяющую найти и выв

ести максимальное значение среди трехзначных элементов массива, делящихся на 4. Если в исходном массиве нет трехзначного элемента, который делится на 4, то вывести сообщение о том, что такого числа нет.



Вы находитесь на странице вопроса "Дан целочисленный массив из 31 элемента, в котором записаны значения температуры воздуха в марте. Элементы массива могут принимать значения от (–20) до", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.