Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу, в которую пользователь вводит число а компьютер выводит сообщение о том в каком интеревале оно лежит 1 до 10 , от 11 до 20 , от

10-11 класс

21 до 30, и 31 до 40,
В паскале.

MoLaFFka 21 нояб. 2014 г., 16:39:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anna1951
21 нояб. 2014 г., 17:14:26 (9 лет назад)

Пишу на QBasic
CLS
INPUT A
IF A<10 THEN
PRINT (1<A<10)
ELSE
IF A<20 THEN
PRINT (10<A<20)
ELSE
IF A<30 THEN 
PRINT (20<A<30)
ELSE 
IF A<40 THEN 
PRINT (30<A<40)
ELSE
PRINT (40<A)
END IF

+ 0 -
Шелка
21 нояб. 2014 г., 18:47:45 (9 лет назад)

тут нужно использовать условные конструкции, не знаю какой у них синтаксис в паскале, но в PHP такой
if($number <=10) {
echo = "Ваше число меньше или равно 10";
}
elseif($number <=20 and $number>10){
echo = "Ваше число больше 10,но меньше 20";
}
else{
echo="у вас другое число";
}

$number - переменная
echo - аналог write в паскале

Ответить

Другие вопросы из категории

Построить последовательность чисел Фибоначчи: F=0,1,1,2,3,5,8,13,….n.

Числа Фибоначчи : последовательность, каждый следующий элемент которой равен сумме 2-х предыдущих., причем известно, что первый член последовательности f0=0, в второй f1 =1.

Помогите , мне нужны комментарии к этой программе.

Срочно!!
#include <stdlib.h>
#include <conio.h>
#include <stdio.h>
int schet(char *s);
int main() {
char vvod[100];
puts("Vvedite stroku:");
gets(vvod);
printf("%i \n", schet( vvod ));
system("pause");
return 0;
}

int schet(char *s)
{
int dlina, i, sum=0;
for(dlina=0; s[dlina]!='\0'; dlina++);
for(i=0; i if(s[i]>='0' && s[i]<='9')
{
sum=sum+s[i]-'0';
}
return sum;
}

Читайте также

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [A, B]. Числа A и B задает пользователь.

Программу реализовать с помощью трех циклических алгоритмов:
1) Цикл со счетчиком for
2) Цикл с предусловием while
3) Цикл с постусловием repeat
В программе предусмотреть ситуацию, когда пользователь вводит значение B ‹ A
Пример 1:
Пользователь вводит числа A=5, B=10. Сумма чисел: 5+6+7+8+9+10. Вывод на экран: 45
Пример 2:
Пользователь вводит числа A=7, B=4. Сумма чисел: 4+5+6+7. Вывод на экран: 22
Пример 3:
Пользователь вводит числа A=5, B=5. Сумма чисел: 5. Вывод на экран: 5

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

написать программу на языке паскаль

пользователя вводит числа с интервалом 0,1
у=3х*х+х-4 на отрезке от а до в



Вы находитесь на странице вопроса "Написать программу, в которую пользователь вводит число а компьютер выводит сообщение о том в каком интеревале оно лежит 1 до 10 , от 11 до 20 , от", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.