Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

есть прога: program WTF; {$APPTYPE CONSOLE} uses

5-9 класс

SysUtils;
var
a,b,c,d:real;
begin
read(a,b,c,d);
if d=0 then begin
while (sqr(a)*b<288) do begin
b:=b+1;
end;
d:=a*sqr(b);
end
else if c=0 then begin
b:=sqrt(d)*(-1);
while (a*sqr(b)<>81) do begin
a:=a+1;
end;
c:=sqr(a)*b;
end;
writeln(a:1:0,' ',b:1:0,' ',c:1:0,' ',d:1:0);
end.

но она постоянно получает тайм аут, помогите увеличить скорость ее работы любым путем

Naskaokey123 21 окт. 2013 г., 13:45:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bliznyaknata
21 окт. 2013 г., 15:37:46 (10 лет назад)

это вам не сюда,зайдите на любой сайт о компьютерах и задайте вопрос на форуме

Ответить

Другие вопросы из категории

Если за один такт процессор может обрабатывать представленное количество информации:

1 0 1 1 1 0 0 1 1 0 1 1 1 0 0 1

то разрядность процессора равна:

СВЕТОВОЕ ТАБЛО СОСТОИТ ИЗ ЛАМПОЧЕК, КАЖДАЯ ЛАМПОЧКА МОЖЕТ НАХОДИТСЯ В ОДНОМ ИЗ ТРЕХ СОСТОЯНИЙ : ВКЛЮЧЕНА, ВЫКЛЮЧЕНА,МИГАЕТ. КАКОЕ НАИМЕНЬШЕЕ КОЛИЧЕСТВО

ЛАМПОЧЕК ДОЛЖНО НАХОДИТСЯ НА ТАБЛО, ЧТОБЫ С ЕГО ПОМОЩЬЮ ПЕРЕДАТЬ 18 РАЗЛИЧНЫХ СИГНАЛОВ?

Выберите ответ , в котором соответствие установлено наиболее точно в связи с предназначением данного типа редактора . 1.электронная таблица a.абзац

2.текстовый редактор b.изображение 3.графический редактор c.ячейка 4.звуковой редактор d.тег 5.HTML-редактор. e.трек

Читайте также

Одной из задач, возникающей при разработке поисковых систем, является поиск самых популярных сайтов по ключевым словам (тегам), описывающим сайт. Дан

список сайтов. Про каждый сайт известны набор тегов сайта и его популярность. Есть запрос в виде набора тегов. На запрос необходимо выдать самый популярный сайт, у которого в описании встречаются все теги из запроса.
Формат входного файла

В первой строке входного файла input.txt находится набор тегов, разделённых ровно одним пробелом, количество тегов не превосходит 5. Тегом назовём такую строку, которая содержит только строчные латинские буквы и ее длина не превосходит 10 символов. В следующей строке дано число N (1 ≤ N ≤ 20)— количество сайтов.

Каждый сайт описывается тремя строками. В первой строке название сайта. Название сайта состоит только из строчных латинских букв и точки. Длина названия сайта не превосходит 15 символов. Во второй строке набор тегов сайта, разделенных пробелами. Количество тегов не превосходит 10. В третьей строке число Ai(1 ≤ Ai ≤ 1000000)— популярность сайта.
Формат выходного файла

В выходной файл output.txt требуется вывести любой самый популярный сайт, у которых встречаются все теги из запроса. Гарантируется, что найдётся, хотя бы один сайт отвечающий запросу.
Пример входных и выходных данных

Input.txt
football volleyball
5
sportbox.ru
sport football volleyball basketball swimming hockey
5000
championat.com
sport football volleyball basketball hockey
4000
soccer.ru
sport football
6000
sport.ru
sport football vоlleyball
1000
sports.ru
sport football volleyball basketball swimming hockey
2000

Output.txt

sportbox.ru

Я задачу решила, на мои тесты работает.

Однако, когда я отправляю ее тестировать на сайт, вылезает что программа выдала неправильный ответ.

program Project2;

{$APPTYPE CONSOLE}

uses
SysUtils;

var
s,r:string;
tegs,sait,d,x1:array[1..255] of string;
pop,l,x:array[1..100000] of integer;
i,j,k,n,f,max,max1:integer;
begin
assign(input,'Input.txt');reset(input);
assign(output,'Output.txt');rewrite(output);
readln(s);s:=s+' ';f:=0;
for i:= 1 to length(s) do begin
if s[i]<>' ' then r:=r+s[i];
if s[i]=' ' then begin k:=k+1;d[k]:=r;r:='';end;
end;
readln(n);
for i:= 1 to n do begin
readln(sait[i]);
readln(tegs[i]);
readln(pop[i]);
end;
for i:= 1 to n do begin
for j:= 1 to k do begin
if pos(d[j],tegs[i])<>0 then f:=f+1;
end;
l[i]:=f;
f:=0;
end;
max:=0;max1:=0;
f:=0;
for i:=1 to n do
if l[i]>max then max:=l[i];
for i:=1 to n do
if l[i]=max then begin inc(f);x[f]:=pop[i];x1[f]:=sait[i];end;
for i:=1 to f do
if x[i]>max1 then begin max:=x[i];k:=i;end;
writeln(x1[k]);
close(input);close(output);
end.

Program Pr1;

uses crt;
var fl1,fl2:text;
i,n,v,a,b:integer;
Begin
clrscr;
assign(fl1,'input.txt');
assign(fl2,'output.txt');
reset(fl1);
readln(fl1,n);
v:=0;
for i:=1 to 1000000 do begin
if i>=10 then begin
a:=i div 10;
b:=i mod 10;
if (a mod 2<>0) and (b mod 2<>0) then v:=v 1;
end
else if i mod 2<>0 then v:=v 1;
if v=n then break;
end;
rewrite(fl2);
writeln(fl2,v);
close(fl1);
close(fl2);
end.

ребят в этом алгоритме есть ошибка найдите её плз

ЕСТЬ ОШИБКИ? program z1; uses crt; var a,b,c:integer y:real; begin crlscr; Writeln('vvedi 3 chisla');

Readln(a,b,c);

if a>=0 then y:=a+b+c

else if(a0 then y:=exp(a*In(c))

else y:=0;

Writeln(y:2:2);

readln;

end.

Паскаль шифр цезаря

почему при дешифровке в слове с буквой "в" в результате выдаёт восклицательный знак то есть не может его дешифровать?




program SHIFR_CEZERYA;
uses crt;
var a,b,c:string;
i,j,k,d,g:integer;
begin
clrscr;
writeln('Шифрование?1-да,0-нет');
readln(g);
writeln('Исходный текст ');
readln(a);
writeln('ключ');
readln(d);
c:=''; //Результат
b:='абвгдеёжзийклмнопрстуфхцчшщъыьэюя';
for i:=1 to length(a) do //цикл
for j:=1 to length(b) do
begin
If g=1 then k:=(j+d) mod 33 else k:=(j-d)mod 33;
If k>33 then k:=k-33;
if k<0 then k:=k+33;
if a[i]=b[j] then c:=c+b[k];
end;
writeln(c);
readkey;
end.



Вы находитесь на странице вопроса "есть прога: program WTF; {$APPTYPE CONSOLE} uses", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.