Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ЕСТЬ ОШИБКИ? program z1; uses crt; var a,b,c:integer y:real; begin crlscr; Writeln('vvedi 3 chisla');

5-9 класс

Readln(a,b,c);

if a>=0 then y:=a+b+c

else if(a0 then y:=exp(a*In(c))

else y:=0;

Writeln(y:2:2);

readln;

end.

Kovalevd9 14 авг. 2014 г., 2:10:11 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Niknadin1500
14 авг. 2014 г., 2:48:51 (9 лет назад)

Нет,всё правильно.........

Ответить

Другие вопросы из категории

что из перечисленного характеризует векторную графику?

10) пикселизация при масштабировании
11) сфера применения - обработка фотографий
12) минимальный объект - графический примитив (линия, эллипс и т.д.)
13) сфера применения - полиграфия, реклама
14) компактность представления, малый размер файлов
15) минимальный объект - точка
16) изображения легко преобразуются без потери качества
17) достаточно большой размер файлов

Читайте также

помогите решить задачи по информатике (на уровне знаний 7 класса) с помощю PascalABC

1. Дано 2 числа найти модуль разности этих чисел увеличенный в 5 раз.
2. Дано 4 значное число поменять местами 1 и 2 цифру местами
3. Дан диаметр круга найти его площадь (формула S=п*R).
Я примерно знаю как писать но всеровно нуждаюсь в помощи
Мои мысли:
program z1;
uses crt;
var ... : integer;
begin
дальше всё в тумане
буду рад за решённые 1 или 2 задачи

Помогите найти ошибку в программе (Массив)

Program Ah;
uses crt;
var A:array[1..15] of integer;
i,k,n:integer;
begin
clrscr;
for i:=1 to 18 do begin
writeln('A[',i,']=');
read(A[i]);
end;
writeln('Введите число');
read(n);
k:=0;
for i:=1 to 15 do begin
if a[i]>n then
k:=k+1;
writeln('k=',k);
readkey;
end.
(В последней строке выдает "Ошибка, ожидается точка с запятой")

Помгите пожалуйста! Найдите ошибки, а то он всякую чепуху считает.Заранее большое спасибо)))) Используя команду ветвления составить программу,

которая определяет, сколько чисел из К являются нечетными.

Program mass;

uses crt;

var i,k:integer;

a:array[1..100] of integer;

begin ClrScr;

k:=0;

randomize;

for i:=1 to 10 do begin

a[i]:=random(10)-5; write( a[i]:3);

if a[i] mod 2=1 then

k:=k+1;

end;

writeln ( 'Кол-во нечетных чисел из K ',k);

readln;

end.

Паскаль шифр цезаря

почему при дешифровке в слове с буквой "в" в результате выдаёт восклицательный знак то есть не может его дешифровать?




program SHIFR_CEZERYA;
uses crt;
var a,b,c:string;
i,j,k,d,g:integer;
begin
clrscr;
writeln('Шифрование?1-да,0-нет');
readln(g);
writeln('Исходный текст ');
readln(a);
writeln('ключ');
readln(d);
c:=''; //Результат
b:='абвгдеёжзийклмнопрстуфхцчшщъыьэюя';
for i:=1 to length(a) do //цикл
for j:=1 to length(b) do
begin
If g=1 then k:=(j+d) mod 33 else k:=(j-d)mod 33;
If k>33 then k:=k-33;
if k<0 then k:=k+33;
if a[i]=b[j] then c:=c+b[k];
end;
writeln(c);
readkey;
end.

program mar; uses crt; var F,k:integer; S:real; begin clrscr; F:=1; S:=1; for k:=1 to 3 do

begin

F:=F*k;

S:=S*(2*F)/(k*k*k*k+k);

writeln('k = ',k );

readkey;

end.

Найдите ошибку, пожалуйста, программа не идет.



Вы находитесь на странице вопроса "ЕСТЬ ОШИБКИ? program z1; uses crt; var a,b,c:integer y:real; begin crlscr; Writeln('vvedi 3 chisla');", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.