Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Цикл с предусловием. Напишите программу и блок схему , пожалуйста:)

10-11 класс

007женя007 22 нояб. 2013 г., 1:58:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dianashbr
22 нояб. 2013 г., 3:23:48 (10 лет назад)

основное устройство ввода информации

Ответить

Другие вопросы из категории

Сравнение

чисел. Написать функцию, которая сравнивает два целых числа и возвращает
результат сравнения в виде кода символов одного из знаков <, >, =.

«Электронный,

домашний, почтовый, абсолютный, относительный, временный». Что это?

Читайте также

1)Найти 3 совершенное число(программа+блок схемы)

2)Определить 35 простое число(программа +блок схемы)
3)Дано:трехзначное число ,определить :является ли произведение его цифр трехзначным числом(программа+блок схемы)

Циклические алгоритмы.СоставьтеЦиклические алгоритмы.Составьте блок- схему для решения следующих задач:

1) Вводятся 100 чисел.Определить сколько среди них положительных и сколько отрицательных.(Числа вводятся в одну переменную в цикле)
2) Алгоритм вычисления суммы квадратов десяти производных чисел, водимых с клавиатуры в процесс выполнения алгоритма
И НАПИШИТЕ ПРОГРАММУ ДЛЯ КАЖДОЙ ЗАДАЧИ

Дан фрагмент программы. Нарисуйте блок-схему, восстановите вид формулы для расчета S

PASCAL:

VAR
A:ARRAY[1...100]OFF
INTEGER;
N,I,J: INTEGER;
S: REAL;
BTGIN
N:=8;
FOR I:=1 TO N DO
BEGIN
S:=0;
FOR J:=1 TO I DO
S:=S+(A[J]);
S:=ABS(S);
WRITELN(`S`=`,S:9:2);
END;
READLN;
END.

QBASIC
DEFINT N,I,J,S,
DIM A(100) AS INTEGER
N:=8
FOR I=1 TO N
S=0
FOR J=1 TO I
S=S+A[J]
NEXT J
S=ABS(S)
PRINT S
NEXT I

ШКОЛЬНЫЙ АЯ

алг слово(рез вещ s)
цел раб А[1:100]
n:=8
нц для I от 1 до n
s=0
нц для j от 1 до I
s=s+a[j]
кц
s=abs(s)
вывод s
кц
кон

Пожааалуйста нужны блок-схемы для трех вариантов получения s





Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.

Нужно составить блок-схему алгоритма подготовки к сдаче к экзамену.

Я не могу сочинить этот "алгоритм", помогите ;)
Блок-схемы строить не надо, просто описать, что надо делать.



Вы находитесь на странице вопроса "Цикл с предусловием. Напишите программу и блок схему , пожалуйста:)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.