Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите решить задачу на любом языке программирования.

5-9 класс

Имеется ряд из N лампочек, которые пронумерованы от 1 до N. Изначально ни одна из лампочек не горит. Далее происходит K последовательных линейных инверсий этого ряда ламп. Под линейной инверсией понимается инверсия каждой P-й лампочки в ряде. Например, если P=3, то произойдет инверсия 3й, 6й, 9й и т.д. лампочек.Требуется определить: сколько горящих лампочек останется после реализации всех заданных линейных инверсий?

Входные данные:
В первой строке входного файла INPUT.TXT заданны числа N и K – число лампочек и число линейных инверсий. Вторая строка состоит из K целых чисел Pi, задающих период данных инверсий. (1 <= N <= 109, 1<=K<=100, 1 <= Pi <= 50)

Aminka05532 17 апр. 2014 г., 0:30:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ника55555555
17 апр. 2014 г., 2:03:00 (10 лет назад)

package test;
import java.io.*;
public class Test {    public static void main(String[] args) throws IOException {         BufferedReader in=new BufferedReader(new InputStreamReader(System.in));
String line = in.readLine();
int N = Integer.parseInt(line);
boolean[] mas = new boolean[N];        
String line2 = in.readLine();       
int K = Integer.parseInt(line2);        
for(int x = 0; x < N; x++){mas[x]=false;}        
for(int z = 0; z < K; z++){String line1 = in.readLine();
            int P = Integer.parseInt(line1);
            for(int i = P - 1; i < N; i = i + P){if (mas[i] == false) {mas[i]=true;}               
                                                         else mas[i] = false;
            }       
}        
for(int l = 0; l < N; l++){if(mas[l]==true){System.out.println("+");}
else System.out.println("-");        }    }}

+ 0 -
Mamsel1803
17 апр. 2014 г., 3:26:05 (10 лет назад)

Комментарий удален

+ 0 -
ТолкачеваВаля
17 апр. 2014 г., 4:04:13 (10 лет назад)

Хорошо, я даже может код переделаю на свой язык

+ 0 -
Ninyysaya
17 апр. 2014 г., 6:01:40 (10 лет назад)

Комментарий удален

+ 0 -
Aesonne
17 апр. 2014 г., 6:35:43 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Скорость передачи данных по некоторому каналу связи равна 32 Кбит/ с. Передача текстового файла по этому каналу связи заняла 48 с.Определите ,сколько

страниц содержал переданный текст ,если известно ,что информационный вес одного символа равен 2 байта , а на одной странице 128 символов.

Читайте также

Помогите решить задачу на языке программирования в Turbo Pascal, плиз Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он

увеличивал пробег на 10% от пробега предыдущего дня. Определить: а) ежедневное увеличение пробега лыжника за третий, четвёртый, ..десятый день тренировок; б) средний путь лыжника за первые 8 дней тренировок; в) сколько дней он будет бегать менее, чем по 15 км; г) в какой день суммарный пробег за все дни превысит 90 км.

PASCAL. нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если рОЧЕНЬ нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если решиш - проси

что угодно, помогу)Вот задача - Под конец учебного года ученики 11 класса решали понять у кого же из них будет самый высокий средний балл ? Известно , что - в классе учится 14 учеников, - Сумма всех средних баллов аттестата = 100.Известно также , что первый ученик имел средний балл, который составляет 1/ 12 суммы всех средних баллов. Второй ученик - на 0,15 % больше, чем первый ученик , но на 1,75 % меньше , чем третий ученик . Средние баллы аттестатов двух сестер были равными среднему арефметичному оценок вышеупомянутых учеников , разделенном на 1.5 . Четвертый ученика на конец года имел такой же балл , как и первый ученик , но на 5% меньше , а остальные ученики - имели равные баллы .Какой средний балл на конец года получил каждЫй?

пожалуйста, помогите решить задачи по Паскалю!!!

1) Даны два числа. Составить алгоритм и перевести его на язык программирования, который меньшее из них возводит в квадрат, а большее оставляет без изменения,

ПОМОГИТЕЕ




Вы находитесь на странице вопроса "Помогите решить задачу на любом языке программирования.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.