Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1-В среде Delphi определить наибольшее из трех чисел 2 Процедура сохранения документа. 3 Создание текстогого редактора

10-11 класс

KristinaRaccon 25 марта 2014 г., 13:13:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alka2576
25 марта 2014 г., 16:09:58 (10 лет назад)

Делфи - обьектно ориентированная среда программирования обжект паскаль. Так что структурно паскалем там катит (работает из-под ДОСа)

1)

var
a,b,c,max,max2, max3:integer;
begin
writeln ('vvedite chisla');
read (a);
read (b);
read (c);
begin
if (a>b) then
begin
max:=a
end;
if (b>a) then
begin
max:=b
end;
if (c>max) then
begin
max2:=c;
end;
if (max>max2) then max3:=max;
if (max<max2) then max3:=max2;
writeln (max3);
end;
end.


Ответить

Другие вопросы из категории

расставьте профессии по мере убывания степени использования

компьютеров:водитель,программист,актер,бухгалтер,журналист,писатель,повар,швея,учитель,директор,министр

Помогите пожалуйста.

Режим найбільш компактного збереження інформації веб- сторінки
а) Текстовий файл;
б) Веб- сторінка, тільки HTML;
в) Веб- сторінка повныстюю

Читайте также

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.



Вы находитесь на странице вопроса "1-В среде Delphi определить наибольшее из трех чисел 2 Процедура сохранения документа. 3 Создание текстогого редактора", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.