Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Пожалуйста, помогите написать программу или хотя бы объясните, что от меня вообще хотят....Найти количество элементов к каждому столбцу прямоугольной

10-11 класс

вещественной матрицы, меньших среднего арифметического всех элементов, рассмотренного столбца.

Карино4ка01 27 дек. 2016 г., 22:30:10 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Богдан1223
27 дек. 2016 г., 23:58:27 (7 лет назад)

var a:array [byte,byte] of real;
i,j,n,m:byte;
s:real;
d,p:word;

begin
write('Введите количество строк n = ');readln(n);
write('Введите количество строк m = ');readln(m);
for i:=1 to n do
for j:=1 to m do
readln(a[i,j]);

s:=0;d:=0;p:=0;
for i:=1 to m do begin
for j:=1 to n do
s:=s+a[j,i];
for j:=1 to n do
if a[j,i]<(s/n) then inc(d);
writeln('Количество элементов в столбце ',i,' прямоугольной вещественной матрицы, меньших среднего арифметического d = ',d,' Среднее арифметическое = ',(s/n):0:4);
p:=p+d;
d:=0;s:=0;
end;
writeln('Общее количество элементов меньших элементов в столбцах = ',p);
writeln('Матрица');
for i:=1 to n do begin
for j:=1 to m do
write(a[i,j],' ');
writeln;
end;
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста с 3 и 4 заданиями!!!
Даны три положительных числа. Если они могут быть длинами сторон остроугольного треугольника, то вычислить его площадь и определить вид треугольника (

равносторонний, равнобедренный или разносторонний), иначе выдать соответсвующее сообщение.

какие из перечисленных ниже устройств входят в состав "минимальной конфигурации" компьютера?:

принтер, процессор, клавиатура, звуковая карта, монитор, оперативная память, устройство CD-ROM? Почему?
(на угад б я так смогла наставить, меня больше интересует вопрос "почему?" Не разочарует только полный ответ)

Читайте также

Помогите написать программу для вычисления примера:

y=cos(v)* \sqrt[3]{1+ sin^{2}(v+a) } ; v=(a+c)/a*c; a= e^{-c} +c; c=2.35

Или хотя бы ход решения, какие операторы использовать и т. п.

Народ,помогите написать программу на dev c++,объяснить)

В отчете предоставить блок-схемы всех
функций, текст программы.

Задача : В целочисленном массиве Х(N) удалить все элементы, расположенные
между максимальным и минимальным элементами. Найти среднее
арифметическое элементов массива до и после удаления. В программе
написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму



Вы находитесь на странице вопроса "Пожалуйста, помогите написать программу или хотя бы объясните, что от меня вообще хотят....Найти количество элементов к каждому столбцу прямоугольной", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.