Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Срооочно!!!

5-9 класс

нужно составить программу на Паскале
на квадратное уравнение!

Аня7994 20 янв. 2014 г., 6:11:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Veronika2001love
20 янв. 2014 г., 7:20:48 (10 лет назад)

var a,b,c:integer;
x1,x2,d:real;
begin
writeln ('Введите коэффициенты уравнения:');
readln (a,b,c);
if a=0 then
writeln('уравнение не квадратное') else
begin  d:=b*b-4*a*c; 
if d<0 then
writeln ('уравнение не имеет действительных корней')
else if d=0 then
begin
x1:=-b/(2*a);
writeln('x1=x2=',x1:0:2);   
end else
if d>0 then
begin
x1:=(-b-sqrt(d))/(2*a);
x2:=(-b+sqrt(d))/(2*a);
writeln('x1=',x1:0:2,'  x2=',x2:0:2);
end;
end;
end.

Ответить

Другие вопросы из категории

Составьте программу, позволяющую вставить слово t после первого слова исходной строки s. Строка s и слово t вводятся с клавиатуры. (PascalABC)

Пример ввода:
Наступила осень
золотая
Пример выводы:
Наступила золотая осень.

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Читайте также

СРОООЧНО!!

Какая из указанных ячеек принадлежит диапазону B5:D24? A23

ПОЖАЛУЙСТА ПОМОГИТЕ,ОЧЕНЬ СРОООЧНО!!!!

Сообщение записано буквами 64 символьного алфавита и содержит 20 символов. Какое количество оно несет!!!!



Вы находитесь на странице вопроса "Срооочно!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.