Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1)среди 15 чисел найдите сумму всех положительных чисел

5-9 класс

2) среди 15 чисел найдите количество всех чисел которые являются не отрицательными

Eshhenko1982 22 янв. 2014 г., 21:23:05 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
XOXANA
22 янв. 2014 г., 22:34:43 (10 лет назад)

var  a: array[0..15] of integer;  i, s, n: integer;
begin    for i := 1 to 15 do   begin    
a[i] := random(20)-10;    
write(a[i], ' ');  
if a[i]>0 then begin 
s:=s+a[i];
n:=n+1;
end;  
end;      
 writeln;  
writeln('Сумма положительных чисел: ',s);
writeln('Количество положительных чисел: ',n);
end.

Ответить

Другие вопросы из категории

Срооочно!!!

нужно составить программу на Паскале
на квадратное уравнение!

Составьте программу, позволяющую вставить слово t после первого слова исходной строки s. Строка s и слово t вводятся с клавиатуры. (PascalABC)

Пример ввода:
Наступила осень
золотая
Пример выводы:
Наступила золотая осень.

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Читайте также

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

написать программу которая в последовательности натур. чисел определяет сумму всех чисел кратных 8 и оканчивающихся на 4.программа получает на вход

натур. числа а также их количество.количество чисел не превышает 1000.программа должна вывести одно число:сумму всех чисел кратных 8 и оканч. на 4
ПОМОГИТЕ, ПОЖАЛУЙСТАА

Пожалуйста помогите решить задачу: Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и

оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.

Пример работы программы:

Входные данные Выходные данные

14 168

24

144

22

12

0

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на

вход натуральные числа через клавиатуру, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4. Пояснение: цикл while x<>0 do с условием if (x mod 6=0) and (x mod 10=4)

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal



Вы находитесь на странице вопроса "1)среди 15 чисел найдите сумму всех положительных чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.