Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В массиве найти элемент, у которого сумма цифр равна произведению.

10-11 класс

Решите, пожалуйста, а то тему не поняла..

Maianna 02 марта 2015 г., 1:53:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ЖЕРАРфернандес
02 марта 2015 г., 3:08:16 (9 лет назад)

const
    n = 100;

var
    a: array[1..n] of integer;
    k, i, s, p: integer;

begin
    for i := 1 to n do
    begin
        a[i] := random(200);
       
        p := 1;
        s := 0;
        k := a[i];
        while(k > 0) do
        begin
            s := s + k mod 10;
            p := p * k mod 10;
            k := k div 10;
        end;
       
        if p = s then
            Writeln(a[i], ' ');
    end;
end.

+ 0 -
AShevorykina
02 марта 2015 г., 5:01:10 (9 лет назад)

что тут непонятного)

Ответить

Другие вопросы из категории

Методом половинного деления вычислить на ЭВМ корень уравнения вида f (x) = 0, расположенный на интервале [a, b] с заданной погрешностью.

Определить число итераций, необходимое для нахождения корня.
3sin√x+0,35x-3,8=0 [2;3] 10^(-3)
НУЖНО ПРЯМ ПРОГРАММУ(

как вывести итоговую сумму в Excel.

первые числа-объем товара, вторые сумма товара.

Читайте также

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

Дано натуральное число N. Найти наименьшее число М (N < M < 2N) которое делится на сумму цифр числа N (без остатка). Если такого числа нет, то

вывести слово «нет». Пример. N = 12 345, М = 12360. Число 12 360 делится на число 15 — сумму цифр числа N

Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В , сумма цифр которых четна. Программа

получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В . Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.



Вы находитесь на странице вопроса "В массиве найти элемент, у которого сумма цифр равна произведению.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.