Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1.Дано целое

10-11 класс

число А. Определить количество цифр в числе, которые больше 6.

Alisherkayumov 18 июня 2016 г., 9:48:21 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
PoLiNa2992
18 июня 2016 г., 10:37:18 (7 лет назад)

Program zz;
var n,x,a:integer;
begin 
readln(a); 
while a>0 do 
begin   
x:=a mod 10;   
if x<6 then n:=n+1;   
a:=a div 10; 
end; 
writeln(n);
end.

Ответить

Другие вопросы из категории

Срочно решите плиз!!!
Программа на Паскале.

Спортсмен принял участие в соревнавании.
Даны переменые

h1, m1, s1,-время старта,
h2,m2,s2-время финиша.

Требуется результат спортсмена в секундах, мин, часах.

Читайте также

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Задача на Паскале. (Действие с целыми переменными).

Дано целое 3-х значное число, в нем крайнюю правую цифру зачеркнули и приписали е слева. Составить программу, реализующую это действие

пожаалуйста

Задание: разработать программу вычисления выходного значения функ-ции y=f(x1,x2,x3,x4). Тип входных и выходных данных, вид функции заданы в табл. 2.

Выходное значение и входные должны отображаться на экране в виде: X1= X2= X3= X4= Y=

Разработать функцию, которая автоматически заполняет массив из 10 наборов входных данных. Массив затем подвергается обработке, т.е. в цикле вычисляются значения функции и выводятся на экран в виде: Y1= Y2= Y3= Y4= , и т.д.

тип входных данных: целое тип выходных данных: целое, функция: x1*sin(x2) + x3*sin(x4)



Вы находитесь на странице вопроса "1.Дано целое", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.