Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дано целое число N больше 1, а также первый член а и разность D арифметической прогрессии сформировать и вывести массив размером n содержащих n первых

10-11 класс

членов данной прогрессии.

Александрушка99 03 марта 2015 г., 14:25:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hedisey
03 марта 2015 г., 17:20:59 (9 лет назад)

program xxx;

   var i, n : integer;

         a, d : real

            s: array[1..20] of real;

begin

   write('введите N-');

   readln (n);

   write('введите а=');

   readln(a);

   write('введите d=');

   readln(d);

   s[1]:=a;

   for i:=2 to n do

     s[i]:=a+d;

   write('Арифметическая прогрессия:'); 

   for i:=1 to n do

        write(s[i]);

end.

 

 

Ответить

Другие вопросы из категории

1. По сторонам треугольника найти его периметр, площадь, высоты и радиус вписанного и описаного кругов.

2. Найти больше из трех данных чисел.
3. В одномерном массиве положительные элементы меншиты на 7.

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

Ребята, напишите, пожалуйста, программу.

Заранее спасибо.

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Даны два целых числа A и B (A < B). Вывести в

порядке возрастания все целые числа, расположенные между A и B(в том числе A и B),
a также количество N этих чисел
ЦИКЛ с ПАРАМЕТРОВ

дано целое число n<=(больше равно) 9999

является ли это число палиндромом?
все ли его цифры разные?

Помогите надо написать программу в паскале. 1)координаты двух различных полей шахматной доски x1, y1,x2, y2 (целые числа, лежащие в диапазоне 1–8).

Проверить истинность высказывания: «Ладья за один ход может перейти с одного поля на другое». 2) Дано трехзначное число. Проверить истинность высказывания: «Все цифры данного числа различны». 3)Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения. Вывести новые значения переменных A и B.



Вы находитесь на странице вопроса "дано целое число N больше 1, а также первый член а и разность D арифметической прогрессии сформировать и вывести массив размером n содержащих n первых", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.