Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дано целое число n<=(больше равно) 9999

10-11 класс

является ли это число палиндромом?
все ли его цифры разные?

Yuluana 20 авг. 2013 г., 9:44:59 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Azbukiwediv
20 авг. 2013 г., 10:45:28 (10 лет назад)

var n,p,d : longint; a : array [0..9] of boolean; v : boolean;

begin

  readln(n);

  d:=n;

  v:=false;

  p:=0;

  while d>0 do

  begin

    p:=p*10+(d mod 10);

    if a[d mod 10]=true then v:=true else a[d mod 10]:=true;

  end;

  if p=n then writeln('Данное число палиндром');

  if not(v) then writeln('Все цифры данного числа разные');

end.
Я не знаю работает ли это, если не работает напиши мне. Я исправлю

Ответить

Другие вопросы из категории

Ребята помогите пожалуйста!!!
1. а) Перечислите задачи, которые должна решать проектируемая информаци­онная система «Приемная комиссия». б) Какие информационные процессы происходят на

различных этапах прием­ной кампании в вузе? в) Какая информация добавляется к базе данных на каждом этапе?

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Даны 2 двузначных целых числа X и y.Найти D=MAX{x+y;y-x}+3,E=MIN{x^2+y^2;y^2+x*y}-4.если D<E,то к переменной D прибавить первую цифру числа

E,иначе из числа взять корень степени, равной второй цифре числа

если есть умеющте напишите,пожалуйста,программу в Паскале

Помогите надо написать программу в паскале. 1)координаты двух различных полей шахматной доски x1, y1,x2, y2 (целые числа, лежащие в диапазоне 1–8).

Проверить истинность высказывания: «Ладья за один ход может перейти с одного поля на другое». 2) Дано трехзначное число. Проверить истинность высказывания: «Все цифры данного числа различны». 3)Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения. Вывести новые значения переменных A и B.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Даны два целых числа A и B (A < B). Вывести в

порядке возрастания все целые числа, расположенные между A и B(в том числе A и B),
a также количество N этих чисел
ЦИКЛ с ПАРАМЕТРОВ



Вы находитесь на странице вопроса "дано целое число n&lt;=(больше равно) 9999", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.