Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

)Какую структуру Будет иметь алгоритм решения следующей задачи? Дано целое положительное число N. Если N — четное, то вычислить N! = 1·2·...·N. Если N —

10-11 класс

Нечетное то вычислить сумму : 1 + 2 + .+N.Составить программу на паскале

Aixioughuxsiohui 09 июня 2013 г., 7:21:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Asus231255
09 июня 2013 г., 8:29:36 (10 лет назад)

разветвляющуюся структуру
var n,f,s,i:integer;
begin
write('Введите целое положительное число N= '); readln(n);
f:=1; s:=0;
if n mod 2 =0 
then begin for i:=1 to n do f:=f*i;writeln(n, '!=', f); end
else begin for i:=1 to n do s:=s+i; writeln('S= ', s) end;
end. 

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЛУЙСТА!!

Перевести число 1985 в двоичную систему
Перевести число -1985 в двоичную систему

----------------------------- СРОЧНО --------------------- Необходимо составить программу в pascal ABC с использованием рекурсии под инвертированием

понимают перестановку первого и последнего элементов этой части, второго и предпоследнего и т.д. а вот само задание ==> Инвертировать часть массива, расположенную между самым левым минимальным в первой половине массива и самым правым максимальным во второй половине массива.

Читайте также

Очень прошу помогите с Паскалем!)

1. Напишите программу, вычисляющую площадь прямоугольника. С клавиатуры вводятся два действительных числа – стороны прямоугольника. Необходимо вычислить его площадь и вывести на экран. Вывод должен быть отформатирован следующим образом: под число отводится 10 знаков, а под вещественную часть – 3.
2. С клавиатуры вводятся 3 целых числа. Определить количество положительных чисел в этом наборе.
3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр.
4. С клавиатуры вводится натуральное число n. Узнайте в нем количество цифр.
5. С клавиатуры вводится натуральное число n. Посчитайте сумму S=1+2+…+n.
6. Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.
7. С клавиатуры вводится натуральное число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса. Попробуйте решить эту задачу без использования массивов.
8. Заполнить элементы массива последовательностью чисел: 2, 5, 10, 17, 26, …
9. Вводится число N, а за ним N целых чисел – элементов массива. Найдите количество отрицательных элементов в этом массиве.
10. С клавиатуры вводится число N. Выведите следующую фигуру (N-строк, на последней строке N звездочек). Подсказка: для решения этой задачи примените конструкцию «цикл в цикле».
*
* *
* * *
* * * *

* * * * * * *
11. Массив заполняется целыми числами до «нуля». Замените все положительные числа массив на противоположные им, а отрицательные возведите в квадрат. Выведите изменившийся массив.
12. На вход программе поступает целое число N. Выведите количество делителей N, включая 1 и само число N. Внимание: для решения этой задачи заведите счетчик и не забудьте сначала занести в него значение 0.

Нерввы на пределе, завтра сдавать, а в процедуре организовать не получается... Составить программу для решения следующей задачи: Дана строка.

Зашифровать ее, переворачивая каждое слово. Создать процедуры для разбиения строки на слова и записи слова в обратном порядке.

Привет, Вася!

!ясаВ ,тевирП



Вы находитесь на странице вопроса ")Какую структуру Будет иметь алгоритм решения следующей задачи? Дано целое положительное число N. Если N — четное, то вычислить N! = 1·2·...·N. Если N —", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.