Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

напишите класс, который принимает с клавиатуры целое положительное число и, если оно как минимум трехзначное и положительное, уменьшает его на 1

10-11 класс

Artemkabasov 05 нояб. 2013 г., 6:56:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Muravevaarina
05 нояб. 2013 г., 7:29:46 (10 лет назад)

type Cl = class
  a:integer;
  constructor Create(b:integer);
  procedure P;
end;

constructor Cl.Create(b:integer);
begin
  a := b;
end;

procedure Cl.P;
begin
  if (a div 100 > 0) and (a > 0) then
  begin
    a := a - 1;
    writeln('new a  = ', a);
  end;
end;

var
  Obj:Cl;
  a :integer;
begin
  write('a = ');
  readln(a);
  Obj := Cl.Create(a);
  Obj.P;
  Readln;
  Obj.Destroy;
end.

Ответить

Читайте также

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было

введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.



Вы находитесь на странице вопроса "напишите класс, который принимает с клавиатуры целое положительное число и, если оно как минимум трехзначное и положительное, уменьшает его на 1", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.