Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В ЭВМ вводятся по очереди данные о росте N учащихся класса. Определить средний рост учащихся класса.

5-9 класс

Alinkasm1999 01 июля 2013 г., 3:45:55 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Klockovova
01 июля 2013 г., 6:06:35 (10 лет назад)

program rost;
var n,i,sred,sum:integer;
A:array [1..10000] of integer;
begin
readln(n);
for i:=1 to n do
readln(A[i]);
for i:=1 to n do
sum:=sum+A[i];
sred:=sum div n;
writeln(sred);
end.

+ 0 -
нарга97
01 июля 2013 г., 7:43:48 (10 лет назад)

Program saidim;
uses crt;
const n=20;
var
  rost,sum,i:integer;
begin
  writeln('***********************');
  writeln('**      Ростомер     **');
  writeln('***********************');
  writeln();
  sum:=0;
  for i:=1 to n do
  begin
    write('Введите рoст ',i,'-го ученика ');
    readln(rost);
    sum:=sum+rost;
  end;
  writeln('*** alphaues is thinking... ***');
  writeln();
  writeln('Средний рост учащихся класса равен ',sum/n);
end.

Ответить

Другие вопросы из категории

Помогите, пожалуйста :*

Составить программу, которая для данной величины А, не используя никаких функций и никаких операций, кроме умножения, вычисляет А15 (А в пятнадцатой степени) за пять операций

Читайте также

Определите средний балл всех решить на С#Определите средний балл всех учащихся по каждому предмету.

Формат входных данных Заданы сначала количество учащихся n, затем n строк, каждая из которых содержит фамилию, имя и три числа (оценки по трем предметам: математике, физике, информатике). Данные в строке разделены одним пробелом. Оценки принимают значение от 1 до 5.
Формат выходных данных Выведите три действительных числа: средний балл всех учащихся по математике, по физике, по информатике.Пример
Ввод Вывод
4 4.75 3.75 4.5
Ivanov Vasiliy 5 3 4
Petrov Sergey 4 3 5
Konstantinov Nikolay 5 5 5
Kuznetsov Ivan 5 4 4

Составьте алгоритм решения задачи и представьте его любым удобным Вам способом (на естественном языке, на псевдокоде/алгоритмический язык, в виде

блок-схемы или на языке программирования Pascal)
1. С клавиатуры вводятся три целых числа. Определите количество положительных чисел в этом наборе.
2. С клавиатуры вводится целое число n. Вычислите сумму S=1+2+3+...+n.
3. С клавиатуры вводится целое число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса.
4. Вводится расстояние L в сантиметрах. Выясните, сколько в нём полных метров. Выведите это количество.

1.Напишите программу вычисления веса идеального мужчины по формуле:

Ид.Вес-Рост в см -100
Значение роста вводится с клавиатуры. Результат вывести в следующем виде:
Для мужчины ростом 165 см идеальный вес равен 65 кг.
2.По аналогии с заданием №1 составить программу, определяющую идеальный вес женщины по следующей формуле:
Ид.Вес=Рост в см - 100 -10% (от Рост в см - 100)

Выберите правильные ответы

1. Закончите предложение: «Алгоритмом называется …»
а) нумерованный список б) маркированный список
в) система команд исполнителя
г) конечная последовательность шагов в решении задачи, приводящая от исходных данных к требуемому результату
2. Что можно считать алгоритмом?
а) правила техники безопасности б) список класса
в) кулинарный рецепт г) перечень обязанностей дежурного по классу
3. Закончите предложение: «Блок-схема – форма записи алгоритмов, при которой для обозначения различных шагов алгоритма используются ….»
а) рисунки б) списки в) геометрические фигуры г) формулы
4. Закончите предложение: «Геометрическая фигура параллелограмм
используется в блок-схемах для обозначения ….
а) начала и конца алгоритма б) ввода или вывода данных
в) принятия решения г) выполнения действия
5. У какого из известных Вам исполнителей следующая СКИ: вверх, вниз, вправо, влево, закрасить?
а) РОБОТ б) Чертежник в) Вычислитель г) ГРИС
6. В следующем списке 12 2,3 0 5 -5 98,0 целых величин:
а) 2 б) 3 в) 4 г) 5
7. Каждая команда алгоритма должна определять однозначное действие исполнителя. Это свойство алгоритма называется…
а ) формальность б) точность в) понятность г) массовость
8. Укажите формальных исполнителей:
а) симфонический оркестр исполняет музыку Ф. Шопена
б) ученик 9 класса решает задачу по алгебре
в) фармацевт готовит лекарство по рецепту
г) автомат на конвейере наполняет бутылки лимонадом
9. Для многократного выполнения одинаковых действий в алгоритме нужно использовать
а) ветвление б) цикл в) линейные команды
10. После выполнения фрагмента алгоритма вида:
S:=0
i:=1
пока i<4
нц
i:=i+1
S:=S+1
кц
значение переменной s равно…. а) 0 б) 3 в) 5 г) 9
11. Переменная х получила значение, равное -6. Какое значение получит переменная у после выполнения ветвления:
если а меньше или равно 3
то у:=а*а
иначе у:= 2а-3
все
а) -6 б) 6 в) 36 г) -15



Вы находитесь на странице вопроса "В ЭВМ вводятся по очереди данные о росте N учащихся класса. Определить средний рост учащихся класса.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.