Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составьте алгоритм решения задачи и представьте его любым удобным Вам способом (на естественном языке, на псевдокоде/алгоритмический язык, в виде

5-9 класс

блок-схемы или на языке программирования Pascal)
1. С клавиатуры вводятся три целых числа. Определите количество положительных чисел в этом наборе.
2. С клавиатуры вводится целое число n. Вычислите сумму S=1+2+3+...+n.
3. С клавиатуры вводится целое число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса.
4. Вводится расстояние L в сантиметрах. Выясните, сколько в нём полных метров. Выведите это количество.

Екатери 20 дек. 2014 г., 20:13:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tima2020
20 дек. 2014 г., 21:38:42 (9 лет назад)

program task1;
var  a, i, kol :integer;
begin
  for i:= 1 to 3 do  begin    readln(a);    if a > 0 then      inc(kol);  end;  writeln(kol);
end.

program task2;
var  n, result :integer;
function summa (x :integer) :integer;  var     i, sum :integer;  begin    for i:= 1 to x do      sum:= sum + i;    summa:= sum;  end;
begin
  readln(n);  result:= summa(n);  writeln(result);
end.

program task3;
var  i, n, growth, sum, kol :integer;  SrGrowth :real;
begin
  readln(n);  sum:= 0; kol:= 0;  for i:= 1 to n do  begin    readln(growth);    sum:= sum + growth;    inc(kol);  end;  SrGrowth:= sum/kol;  writeln(SrGrowth);
end.

program task4;
var  l :integer;
begin
  readln(l);  l:= l div 100;  writeln(l);
end.

+ 0 -
азор
21 дек. 2014 г., 0:05:39 (9 лет назад)

1) var a1, a2, a3, s: integer;
begin    
write('Введите первое число: ');
readln(a1);
write('Введите второе число: ');
readln(a2);
write('Введите третье число: ');
readln(a3);
if a1>0 then s:=s+1;
if a2>0 then s:=s+1;
if a3>0 then s:=s+1;
writeln(s);
end.

2) 

Ответить

Читайте также

Составить алгоритм решения задачи используя алгоритм языка и блок схему.

Найти гипотенузу треугольника.
Помогите пж, и поняятно пишите.
нуужно срочно до завтра!
Заранее большущее спасибо)

1.Составьте блок-схему для решения задачи: Найти площадь S и периметр P прямоугольника. Значения сторон а и в задать произвольно.

2.Составить блок - схему кипячения чайника.

3.Составить алгоритм сбора яблок в саду.Ваша задача сводится к тому,что необходимо собрать ведро яблок с земли.

4.Составьте алгоритм на формальном языке и блок - схему для решения следущего примера : y=5x+6,если х=3

1)Составить алгоритм для решения задачи: Вычислить угол между двумя векторами, если эти векторы заданы своими координатами.2)Составить

алгоритм для решения задачи: Найти действительные корни квадратного уравнения вида ax^2+bx+c=0.



Вы находитесь на странице вопроса "Составьте алгоритм решения задачи и представьте его любым удобным Вам способом (на естественном языке, на псевдокоде/алгоритмический язык, в виде", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.