Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Paskal abc

5-9 класс

Тут задача, в которой нужно ввести верно пароль, ну дак вот нужно составить похожую программу, но так что-бы было 3 попытки ввода пароля, ну и после этих попыток будет например "Вы ввели не верный пароль, попытки исчерпаны"
можно сделать через string
------------------------
program
test1;


var
x,y:integer;


begin


y:=555;


repeat


writeln(‘введите
пароль’);

Veloman 02 июля 2013 г., 1:28:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Smmar
02 июля 2013 г., 2:45:24 (10 лет назад)

program test1;

var
    x, y, i: integer;

begin
    y := 555;
    for i := 1 to 3 do
    begin
        writeln('введите пароль');
        readln(x);
        if y = x then begin
            writeln('Поздравляем, вы ввели пароль верно');
            break;
        end;
    end;
    if x <> y then
        writeln('Попытки исчерпаны');
end.

Ответить

Другие вопросы из категории

Помогите, пожалуйста :*

Составить программу, которая для данной величины А, не используя никаких функций и никаких операций, кроме умножения, вычисляет А15 (А в пятнадцатой степени) за пять операций

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


Paskal abcТут задача, в которой нужноPaskal abc

Тут задача, в которой нужно ввести верно пароль, ну дак вот нужно составить похожую программу, но так что-бы было 3 попытки ввода пароля, ну и после этих попыток будет например "Вы ввели не верный пароль, попытки исчерпаны"
можно сделать через string
------------------------
program
test1;


var
x,y:integer;


begin


y:=555;


repeat


writeln(‘введите
пароль’);


readln(x);


until y=x


writeln(‘Поздравляем,
вы ввели пароль верно’);


end.



Вы находитесь на странице вопроса "Paskal abc", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.