Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан год. Вывести на экран на экран название животного, символизирующего этот год по восточному календарю (cock, dog, pig, rat, bull, tiger, rabbit,

10-11 класс

dragon, snake, horse, sheep, monkey).
Формат входных данных:
Входной файл содержит натуральное число

Тимофей01012000 04 марта 2017 г., 10:21:06 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ALENASEMENOVA2014
04 марта 2017 г., 12:49:59 (7 лет назад)

var
x,y:integer;
a:array [1..12] of string;
begin
a[1]:=cock;
..
a[12]:=monkey;
read(x);
y:=(abs(2016-x) )mod 12;
write(a[y]);
end.

Вроде должно работать. Проверить не могу - сижу с телефона

Ответить

Другие вопросы из категории

Запись числа N в системе счисления с основанием 7 содержит две цифры,запись этого числа в системе счисления с основанием 6 содержит три цифры,а запись в

системе счисления с основанием 13 заканчивается на 3.Чему равно N?Запишите ответ в десятичной системе счисления.

А как нужно писать тогда?
Дано два

массива q(n) и r(n). Найти сумму элементов массива q; произведение элементов r
и создать массив y(n) каждый элемент
которого равен: y

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

Даны действительные числа x, y. Вывести на экран то из них, которое меньше.

Даны два символа (латинские буквы). Вывести их на экран в порядке возрастания по алфавиту.

Составить программу, которая формирует файл записей, содержащих информацию об автомобиле (название модели, год выпуска, цена, цвет), а также найти в

массиве записей и вывести на экран названия моделей красного цвета, випускалиcя в 2000 году.

P.s Помогите пожалуйста, заране огромное спасибо.



Вы находитесь на странице вопроса "Дан год. Вывести на экран на экран название животного, символизирующего этот год по восточному календарю (cock, dog, pig, rat, bull, tiger, rabbit,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.