Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите написать программу на Pascal для определения в двумерном массиве вещественных чисел D [7, 7] суммы всех элементов на главной диагонали.

10-11 класс

DoSKilL 05 марта 2017 г., 4:59:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fomchik
05 марта 2017 г., 6:51:46 (7 лет назад)

VAR   D : array [1..7,1..7] of real; s: real; i,j: Byte;
begin
s:=0;
FOR i:=1 TO 7 DO
FOR j:=1 TO 7 DO D[ i,j]:= RANDOM(10);
FOR i:=1 TO 7 DO
begin
FOR j:=1 TO 7 DO
WRITE ( D[ i,j]);WRITEln();
end;
FOR i:=1 TO 7 DO
FOR j:=1 TO 7 DO if i=j then s:=s+D[i,j];
WRITEln('s=',s);
end.

Ответить

Другие вопросы из категории

Дан год. Вывести на экран на экран название животного, символизирующего этот год по восточному календарю (cock, dog, pig, rat, bull, tiger, rabbit,

dragon, snake, horse, sheep, monkey).
Формат входных данных:
Входной файл содержит натуральное число

Запись числа N в системе счисления с основанием 7 содержит две цифры,запись этого числа в системе счисления с основанием 6 содержит три цифры,а запись в

системе счисления с основанием 13 заканчивается на 3.Чему равно N?Запишите ответ в десятичной системе счисления.

А как нужно писать тогда?

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

Помогите написать программу в паскале. За ранее спасибо.

Задача на одномерный массив.

Задание 2.
Задан одномерный массив MAS2 [1..10].
Массив объявите как константу типа Integer размером [1..10] со следующими значениями: (-7, 89, 64, -43, 4, 6, 8, -12, 55, 99)
Замените все положительные элементы одномерного массива на их квадраты, а отрицательные удвойте.
Результат вывести на экран.
Вычислить сумму всех элементов нового массива и вывести на экран.

Исходный массив Новый массив
-7 -14
89 7921
64 4096
-43 -86
4 16
6 36
8 64
-12 -24
55 3025
99 9801
Сумма элементов нового массива 24835

помогите написать программы на паскале 1.вычислить произведение 3-х вводимых чисел которые меньше 20. 2. вывести на экран

количество четных и количество нечетных чисел в диапазоне от Х до У.



Вы находитесь на странице вопроса "Помогите написать программу на Pascal для определения в двумерном массиве вещественных чисел D [7, 7] суммы всех элементов на главной диагонали.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.