Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

найдите трехзначное число, равное сумме десятков, квадрата цифры сотен и куба цифры единиц, напишите программу пожалуста

10-11 класс

KonovalovD 20 дек. 2016 г., 7:33:41 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
сороксем
20 дек. 2016 г., 9:37:16 (7 лет назад)

uses crt;
var i,s,e,d,so:integer;
begin
for i:=100 to 999 do
begin
e:=i mod 10;
d:=(i div 10) mod 10;
so:=i div 100;
s:=d+so*so+e*e*e;
if i=s then writeln(i);
end;
end.



Ответить

Другие вопросы из категории

Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы

массива A. 4) Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов). 5) Разделить на 2 все элементы массива A, кроме первого и последнего (считать, что в массиве есть, по крайней мере, два элемента и все элементы чётные). 6) Умножить на 3 все элементы во второй половине массива A (считать, что в массиве чётное число элементов). 7) Найти среднее арифметическое всех элементов массива A.

Читайте также

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

1. Получить все шестизначные числа, в диапазоне от 0 до 999999, у которых сумма первых трех цифр

равна сумме последних трех цифр. Если в числе меньше шести цифр, то оно слева дополняется нулями.

Датчиком случайных чисел

сгенерируйте натуральное число в интервале от 100 до 900. Найдите трехзначное
число, состав ленное из тех же цифр, но записанных в обратном порядке.
Прграмма для выполнения Microsoft visual studio C++

Датчиком случайных чисел

сгенерируйте натуральное число в интервале от 100 до 900. Найдите трехзначное
число, состав ленное из тех же цифр, но записанных в обратном порядке.

Числа Фибоначчи – элементы числовой последовательности 0, 1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144, 233, 377, 610, 987, 1597, 2584, 4181, 6765,

…, в которой каждое последующее число равно сумме двух предыдущих чисел. Количество простых чисел среди первых сорока пяти чисел Фибоначчи составляет …



Вы находитесь на странице вопроса "найдите трехзначное число, равное сумме десятков, квадрата цифры сотен и куба цифры единиц, напишите программу пожалуста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.