Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать фрагмент суммирования матрицы 10 x 10. Решите пожалуйста.

10-11 класс

Vzik06710 18 окт. 2016 г., 23:35:07 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rathash
19 окт. 2016 г., 1:22:34 (7 лет назад)

const m = 10;
n = 10;
 
var a: array[1..m,1..n] of byte;
s: array[1..n] of byte;
i,j, sum: byte;  

begin
randomize;  
for i := 1 to m do begin
for j := 1 to n do begin
   a[i,j] := random(10);
   write (a[i,j]:3)
end;
writeln end;  
writeln ('------------');  
for j := 1 to n do begin
for i := 1 to m do begin
s[j] := s[j] + a[i,j];
sum := sum + a[i,j]
end;
write (s[j]:3)
end;  
write (' | sum = ', sum);  
readln
end.

Ответить

Другие вопросы из категории

паскаль.

есть n количество студентов и t время. блоха сидит на первом студенте. и за каждую секунду прыгает на следующего. программа должна вывести на каком студенте блоха окажется по окончании времени

мышь какаю функцию выполняет
что такое программа?
построить график функции в QBasic? y=ax+b a=3,b=1

вот программа,но надо составить немного проще...без клеточек.
20 SCREEN 12

30 VIEW (10, 10)-(300, 300), , 3

40 WINDOW (-10, 10)-(10, -10)

50 FOR x = -10 TO 10

60 LINE (x,
-10)-(x, 10), 7

Читайте также

Люди,прошу вас, помогите пожалуйста, я уже долго сижу над этой задачей,не могу решить,пожалуйста помогите! =(((

найти номер третьего положительного элемента в потоке из 10 чисел или сообщить,что трех положительных элементов нет. (Решать без массива)

Решите пожалуйста!

Это информатика, 10 класс
Вопросы на фотографии
Номера 5 и 6 не надо решать

Здравствуйте, решите, пожалуйста, 1,2,5,7,8,9,10.
Написать программу вычисления значения переменной y.

решите пожалуйста 1 задачку.. как можно скорее.. спасибо зарание!



Вы находитесь на странице вопроса "Написать фрагмент суммирования матрицы 10 x 10. Решите пожалуйста.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.