Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 981 ответов!

Помогите, пожалуйста.

10-11 класс

В паскале.

найти все двузначные числа, сумма кубов цифр которых делится на 17. (использовать вложенные циклы)

Дарина149 25 сент. 2014 г., 18:54:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Irina20021
25 сент. 2014 г., 20:27:30 (9 лет назад)

Uses crt;
Var i,j,n1,k1,k2:integer;
Function kub (a:integer) :integer;
Var i,n:integer;
Begin
n:=1;
For i:=1 to 3 do
n:=n*a;
kub:=n;
End;

Begin
Clrscr;
For i:=10 to 99 do
Begin
n1:=i div 10;
k1:=kub(n1);
n1:=i mod 10;
K2:=kub(n1);
if (k1+k2) mod 17 = 0 then writeln(i);
End;
Readkey;
End.

+ 0 -
Vero555
25 сент. 2014 г., 21:00:27 (9 лет назад)

у меня всё решенное , ленюсь переписать

+ 0 -
Tvadimov
25 сент. 2014 г., 23:41:40 (9 лет назад)

Комментарий удален

+ 0 -
тайлер
26 сент. 2014 г., 1:18:45 (9 лет назад)

ответ такой. 98 и 89 сумма кубов этих цифр, делятся на 17 и всё

+ 0 -
ViksViksViks
26 сент. 2014 г., 2:33:37 (9 лет назад)

может я где то сделал ошибку или что то еще , сделай по своему и проверь мой ответ

+ 0 -
Asylai9090
26 сент. 2014 г., 3:18:05 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Петя записал IP-адрес школьного сервера на листке бумаги и положил его в карман куртки. Петина мама случайно постирала куртку вместе с запиской. После

стирки Петя обнаружил в кармане 4 обрывка с фрагментами IP-адреса. Эти фрагменты обозначены буквами А 0.144 ;Б 146. ; В 15; Г .100 в ответе укажите последовательность букв, обозначающих фрагменты, в порядке, соответствующем IP-адресу

В упаковке лежат черные и оранжевые фломастеры. Всего в упаковке 64 фломастера. Информация о том, что из упаковки случайным образом достали оранжевый

фломастер, равна 5 битам. Определить, сколько в упаковке черных и сколько оранжевых фломастеров.

В некоторой стране автомобильный номер состоит

из 8 символов. Первый символ – одна из 26 латинских букв, остальные семь –
десятичные цифры. Пример номера – A1234567. Каждый символ кодируется минимально возможным
количеством бит, а каждый номер – одинаковым и минимально возможным количеством
байт. Определите объем памяти, необходимый для хранения 30 автомобильных
номеров.

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.



Вы находитесь на странице вопроса "Помогите, пожалуйста.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.