Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу, которая позволяет просматривать текстовые файлы (выводит на экран содержимое файла) , например, файлы исходных программ Turbo Pascal.

10-11 класс

Имя просматриваемого файла должно вводится во время работы программы. Рекомендуемый вид экрана приведен ниже. Просмотр текстового файла. Введите полное имя файла и нажмите . -> d:\tp\pas\numb.pas

Olegger 19 нояб. 2016 г., 6:30:08 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Margopolovkova
19 нояб. 2016 г., 8:17:50 (7 лет назад)

var f1:text;
st:string;
begin
write ('введите имя файла ');
readln(f1);
reset (f1); { открыть файл для чтения }
while not eof (f1) do { пока не конец файла  f1}
begin
readln (f1, st);    {читаем строку из файла f1 }
writeln(st);         { выводим на экран }
end;
close (f1); { закрыть файл  для чтения}
end .

+ 0 -
Alin4ikbest97
19 нояб. 2016 г., 10:50:01 (7 лет назад)

плииз(((

Ответить

Читайте также

--- Задача 7 ---

Просмотрщик
текстовых файлов. Написать программу, которая позволяет просматривать текстовые
файлы (выводит на экран содержимое файла). Имя просматриваемого файла должно
вводиться с клавиатуры. Вывод содержимого файла произвести постранично.

Примечание:
Результат работы с данными вывести на экран и в новый файл. Файл с входными
данными имеет название INPUT.TXT для текстовых файлов.


на PascakABC оч нужно..плизз

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

эллементы массива вычисляются по формуле A(X,Y)=2X^2-Y^2 написать программу, которая выводит на экран значения элементов массива А(2,2).

подсчитать количество отрицательных элементов

сумму положительных элементов

ВЫВОДИТ НА ЭКРАН НОМЕРА ВСЕХ ЭЛЕМЕНТОВ, ЗНАЧЕНИЯ КОТОРЫХ =0



Вы находитесь на странице вопроса "Написать программу, которая позволяет просматривать текстовые файлы (выводит на экран содержимое файла) , например, файлы исходных программ Turbo Pascal.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.