Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Напишите программу, которая вводит число, не превышающее 45,

5-9 класс

и определяет, изменяется ли сумма цифр этого числа при умножении его
на два. Ответ прикрепите в виде файла в среде PascalABC.

Lalala16 30 марта 2014 г., 17:00:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sov102mailru
30 марта 2014 г., 18:22:43 (10 лет назад)

vara,b,c,d,e,f:integer;
begin
  writeln('a');
  readln(a);
  c:=a mod 10;
  d:=a div 10+c;
  a:=a*2;
  e:=a mod 2;
  f:=a div 10+e;
 if f=d then
   writeln(f,' Равно ',d)
 else
   writeln(f,' Не равно ',d);
end.

Ответить

Читайте также

1. Напишите программу, которая вводит трехзначное число и разбивает

его на цифры. Например, при вводе числа 123 программа должна
вывести 1, 2, 3.
2. Напишите программу, которая вводит возраст человека (число, не
превосходящее 120) и выводит на экран этот возраст со словом «»год,
«года» , «лет» . например «21 год», «22 года», «15 лет»

Помогите пожалуйста !!!!

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

Играют двое . Первый участник игры называет произвольное целое число ,не превышающее 10.Второй игрок прибавляет свое произвольное число к числу названному

первым игроком .к этой сумму первый игрок также прибавляет произвольное число не превышающее 10 ,и сообщает новую сумму .И т.д до тех пор пока окончательной суммой не окажется число 100 .выигрывает тот, кто первый достигнет 100.как должен действовать первый игрок , чтобы выиграть?
ПОМОГИТЕ ПЛиз

Играют двое. Первый участник игры называет произвольное целое положи­тельное число, не превышающее десяти, то есть он может назвать число десять и всякое м

еньшее десяти положительное число. Второй игрок прибавляет к на­званному числу свое целое положительное число, также не превышающее десяти, и называет сумму. К этой сумме первый прибавляет какое-либо положительное число, не превышающее десяти, и сообщает сумму. Выигрывает тот, кто пер­вый достигнет ста.
Как добиться победы?



Вы находитесь на странице вопроса "Напишите программу, которая вводит число, не превышающее 45,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.