Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны три различных целых числа. Определить, найдется ли хотя бы две пары чисел, разность между парами этих чисел одинакова.

5-9 класс

Okaraalina 13 июня 2013 г., 14:17:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tigrrra
13 июня 2013 г., 15:31:27 (10 лет назад)

// Числа 
int first(1), 
....second(2), 
....third(3); 

// Остатки от деления на 2 
double remain1(first%2), 
....remain2(second%2), 
....remain3(third%2); 

// Если есть одна из трех пар, где оба остатка false, т. е. нулевые 
if ( !remain1 && !remain2 || 
!remain2 && !remain3 || 
!remain1 && !remain3 ) 

....printf("Yes!"); 

else 

....printf("No!"); 
}

Ответить

Другие вопросы из категории

Читайте также

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

1. дано натуральное двух значное число определить будет ли цыфра десятков больше чем цыфра единиц.Тема паскаль 2) даны два

натуральных числа вывести на экран то из них у которого цыфра меньше. пожалуйста решите 2 задачи

Составьте программу, которая получает на вход с клавиатуры три различных целых числа a,b,c (каждое число – с новой

строки) и выводит на экран сумму максимального и следующего за ним по величине числа. Каждое число по абсолютной величине не превышает 10 000.



Вы находитесь на странице вопроса "Даны три различных целых числа. Определить, найдется ли хотя бы две пары чисел, разность между парами этих чисел одинакова.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.