Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны два

5-9 класс

числа. Найти их наибольший общий делитель.

(Паскаль)


Fedkinmisha 09 нояб. 2013 г., 17:24:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
BeZdna
09 нояб. 2013 г., 20:00:32 (10 лет назад)

var n, k, nod:integer;

begin
     readln(n, k);
     if (n > k) then
     begin
          nod:=k;
     end;
    
     if (n < k) then
     begin
          nod:=n
     end;
    
     if (n = k) then
     begin
          nod:=n;
     end;

     while(true) do
     begin
          if (k mod nod <> 0) then nod:=nod-1;
          if (n mod nod <> 0) then nod:=nod-1;

          if (k mod nod = 0) and (n mod nod = 0) then break;
     end;
    
     writeln('Наименьший общий делитель: ', nod);
end.

Ответить

Другие вопросы из категории

Если покупатель в магазине покупает товары от 1000 до 2000 то получает 5 % скидку,а если от 2000 то получает 10% Исходя из данных составить эл.

таблицу. А - И.Ф. покупателя В - стоимость покупки С - оплата (формула только в "оплата",там нужно через =если...)

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ

1)Даны два целых числа A и B (A < B). Найти сумму квадратов всех целых чисел

от A до B включительно.
2)Даны натуральные числа от A до B(A<B). Найти произведение тех из них, которые делятся на 3 и не делятся на 4.
3)Ангелина узнав, что Боря занимается спортом, решила не отставать. Она каждый день делала от 3 до 5 упражнений на икры (вводится во время выполнения программы) и 5 упражнений на пресс. Сколько упражнений она сделала за 5, 10 и 13 дней. (количество упражнений на икры на каждый день вводится отдельно)




Вы находитесь на странице вопроса "Даны два", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.