Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите написать программу в паскале и подробно описать

5-9 класс

Присвойте z значение большего из x и y в том случае если x<0 и меньшего если x>=0

балик 13 авг. 2013 г., 10:29:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gordeeva2
13 авг. 2013 г., 13:06:28 (10 лет назад)

var x,y,z:integer; {описание переменных и их типа}
begin
writeln ('введи два числа'); {Вывод на экран сообщения-подсказки}
readln (x,y); {считывание переменных}
if x<0 then                      {проверка условия.}
  if y>x then z:=y             {если условие истинно, то мы ищем большее из х и у. если                                        у больше, то присваиваем z значение у}
           else z:=x             {если же больше х, то присваиваем его значение}
        else                        {если условие ложно}
           if y>x then z:=x     {то мы ищем меньшее из х и у. если                                                                           у больше, то присваиваем z значение х}
                    else z:=y;     {если же больше х, то присваиваем значение у}
writeln (z);                        {вывод результата на экран}
end.                                 {конец программы}

Ответить

Другие вопросы из категории

В терминологии сетей TCP/IP маской сети называют двоичное число, которое показывает, какая часть IP-адреса узла сети относится к адресу сети, а

какая – к адресу узла в этой сети. Адрес сети получается в результате применения поразрядной конъюнкции к заданному адресу сети и его маске. По заданным IP-адресу сети и маске определите адрес сети:

1.Составьте блок-схему для решения задачи: Найти площадь S и периметр P прямоугольника. Значения сторон а и в задать произвольно.

2.Составить блок - схему кипячения чайника.

3.Составить алгоритм сбора яблок в саду.Ваша задача сводится к тому,что необходимо собрать ведро яблок с земли.

4.Составьте алгоритм на формальном языке и блок - схему для решения следущего примера : y=5x+6,если х=3

Читайте также

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






Ребятки помогите плз 75 баллов дам!!!!

помогите написать программу в паскале.
а-3х значное число с клавиатуры. если оно перевёртыш печатать "да" если иначе "нет"
спасибо,

Ребят) Помогите с программой на Паскале, пожалуйстаа)

Нужно написать программу, которая выводит на экран все двухзначные числа, делящиеся на 3 или на 5 (использовать операции целочисленного деления div или mod)



Вы находитесь на странице вопроса "Помогите написать программу в паскале и подробно описать", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.