Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составьте программу, заменяющую из двух данных чисел меньшее число суммой, а большее – произведением этих чисел.

10-11 класс

Asdwqa 13 нояб. 2014 г., 9:41:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Максд
13 нояб. 2014 г., 11:59:14 (9 лет назад)

program pf;
var x,y,a,b:integer;
begin
read(x);
read(y);
a:=x; b:=y;
if x>y then begin x:=a*b; y:=a+b; end else begin x:=a+b; y:=a*b; end;
write(x,y);
end.

Ответить

Другие вопросы из категории

Помогите плиз решить ничего не понимаю заранее спасибо

1.Сколько раз будет выполнена команда повторения в приведенных фрагментах при n=7:
1) for i :=n downto 4 do;
2)S:=S * i.
2. Определите, какой будет результат приведенного фрагмента: a:=100, n:=4:
for i:=1 to n do
a:=a - 2 * i.
Очень важно помогите.

В офисе 8 компьютеров. У программиста есть 3 тестовых копии программы. Сколькими разными способами программист может установить копии программы, при

условии, что на один компьютер имеет смысл ставить только один экземпляр тестовой программы?

1)Дан фрагмент электронной таблицы в режиме отображения формул.(фото с цифрой 1)

Какой вид примет таблица после выполнения команды:КОПИРОВАТЬ B1 в B2:B3.
2)Дан фрагмент электронной таблицы в режиме отображения формул.(фото с цифрой 2)
Чему будут равны значения клеток B2 и B3 в режиме отображения после выполнения команды: КОПИРОВАТЬ B1 в B2:B3.

Что показывает ip-адрес?

Читайте также

1. Составьте блок-схему и программу вычисления значения функции:

2. Составьте программу, определяющую, является ли данное число делителем числа 3.
3*. Составьте программу, заменяющую из двух данных чисел меньшее число суммой, а большее – произведением этих чисел.

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

№1.Составьте программу,выбирающую из всех вводимых в ЭВМ чисел только те, которые входят в интервал от 1 до 5.Ввод производится до тех пор пока сумма

всех введенных данных чисел не будет равна 177. №2. Определите диаметр круга, радиус, площадь, если известна длина окружности L. №3.Даны два действительных числа А, В. Найти наибольшее из них и выяснить четное оно или нет.



Вы находитесь на странице вопроса "Составьте программу, заменяющую из двух данных чисел меньшее число суммой, а большее – произведением этих чисел.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.