Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Проверочная работа <Линейные алгоритмы> Вариант 2 Составить программы для вычисления: a) Полусуммы кубов

5-9 класс

двух целых чисел с и d;

Ответ дать с точность до трёх знаков после запятой

б) Произведения цифр четырёхзначного числа.

Gurty 16 сент. 2013 г., 16:22:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
маруся4325
16 сент. 2013 г., 18:35:41 (10 лет назад)

а) uses crt;
var c,d:integer;
s:real;
begin
write('Введите число с: ');
readln(c);
write('Введите число d: ');
readln(d);
s:=(power(c,3)+power(d,3))/2;
writeln('Полусумма кубов равна ',s:5:3);
end.

б) uses crt;
var a,x1,x2,x3,x4,s:integer;
begin
write('Введите четырёхзначное число: ');
readln(a);
x1:=a div 1000;
x2:= a-1000*x1;
x2:=x2 div 100;
x3:=a-1000*x1-100*x2;
x3:=x3 div 10;
x4:=a-1000*x1-100*x2-10*x3;
s:=x1*x2*x3*x4;
writeln('Произведение всех цифр в числе ',a,' равно ',s);
end.

Ответить

Читайте также

Проверочная работа<Линейные алгоритмы>

Составить программы для вычисления:

a) Среднего арифметического кубов двух целых чисел m и n.

Ответ дать с точность до трёх знаков после запятой.

б) Дано четырёхзначное число. Найти остаток от деления чисел образованных первыми двумя цифрами и последними двумя цифрами этого числа

Проверочная работа Составить программы для вычисления: a) Периметра и

площади прямоугольного треугольника по заданным длинам двух катетов a и b.

Ответ дать с точностью до трёх знаков после запятой:

б) Cумма цифр положительного пятизначного числа из интервала [10000; 32767]

Зараннее сбасибо

турбо паскаль:пожалуйста сделайте хоть часть.массивы: №1. Вычислить сумму 10 целых чисел. Для обозначения чисел введем имя

массива Х, элементы которого имеют индекс I. Сумму обозначим именем SUM.

Sum = x[1]+x[2]+ … + x[10]

№2. Вычислить сумму 15 чисел вещественного типа. Имя массива обозначается через А, элементы которого имеют индекс I. Сумму обозначим именем SUM.

Sum = А[1]+А[2]+ … + А[15]. Вывести на печать результаты в три столбика: 1 - индекс, 2 – значения элементов массива, 3 – сумму.

№3. Найти все четные по значению элементы массива из N целых чисел. Вывести на печать значения элементов массива и их индекс. Ввод элементов массива производится с клавиатуры.

№4.Найти все четные и нечетные по значению элементы массива из N целых чисел. Вывести на печать значения элементов массива и их индекс. Ввод элементов массива производится с клавиатуры.графика:

1) Нарисовать закрашенный прямоугольник, окружность, линию, точку, прямоугольник, треугольник.

2) Нарисовать цепочку из окружностей одного цвета по горизонтали.

3) Нарисовать цепочку из окружностей одного цвета по вертикали.

4) Нарисовать цепочку из окружностей одного цвета по диагонали.

5) Нарисовать цепочки из окружностей зеленого цвета - по горизонтали, красного цвета - по вертикали и желтого цвета - по диагонали.

6) Нарисовать светильник, уличный фонарь.

7) Составьте программу, выводящую на экран компьютера следующие фигуры:

цветка; снеговика; елки; изображение какого-либо животного;

автомобиля.оператор выббора:

№1. Определить по номеру месяца соответствующее время года.

№2. Ввести номер дня недели и вывести соответствующий ему день недели на русском и английском языках. В противном случае вывести сообщение «Такого номера дня недели не существует».

№3. В случае выполнения выражения 2х+1, необходимо соответственно константам выполнить следующие действия (операторы):

5 вычислить выражение ;

11 вычислить выражение ;

15 k1 должно быть равно целочисленному делению х на 2 (деление нацело);

17 k3 должно быть равно сумме двух операций (х div 3) и ( х mod 3);

19 k2 должно быть равно целому остатку от деления х на 2;

21 вывести строчку из последовательности звездочек *;

23 значению d1 должна соответствовать проверка числовой величины х на четность;

В случае если операции не выполнятся, вывести на экран сообщение: «Приносим извинения, Ваши вводимые данные для работы оператора не подходят, попробуйте ввести следующие числа: 2, 5, 7, 8, 9, 10, 11».

№4. Составить программу для выбора действий из сказки: «Направо пойдешь – коня потеряешь, налево пойдешь – смертью умрешь, прямо пойдешь – друга найдешь». Использовать символьный тип данных.

№5. Группу детей, приезжающую в лагерь для отдыха, распределяют по отрядам:

С 6 до 7 лет – 5 отряд;

С 7 до 9 лет – 4 отряд;

С 9 до 11 лет – 3 отряд;

С 11 до 13 лет – 2 отряд;

С 13 до 15 лет (включительно) – 1 отряд;

Составить программу, которая позволяла бы каждому приезжающему самому определить свой отряд. В лагере имеется персональный компьютер.символьные данные:

№1. Составить программу, которая выведет на экран все прописные буквы латинского алфавита от A до Z в одну строчку.

№2. Вывести на печать все прописные и строчные буквы латинского алфавита от A до Z (от a до z ) в 2 строчки.

№3. Вывести на печать все прописные и строчные буквы латинского алфавита от A до Z (от a до z ) и все прописные и строчные буквы русского алфавита от А до Я (от а до я).

1 строка символов должна быть красного цвета, 2 строка символов - зеленого цвета, 3 строка символов - желтого цвета, 4 строка символов - синего цвета.

№4.Вывести на печать все прописные и строчные буквы латинского и русского алфавитов в обратном порядке с использованием цветовой гаммы для символов.оператор цикла:

1) Вычислить А=А+2, N=N+1, при условии 2A£3N+1. Цикл начинает вычисление выражений со значений

А=1, N=1. (Оператор цикла с предусловием)

2) Вычислить Y=X2, при X=8,6,4,2. (Оператор цикла с послеусловием)

3) Вычислить A=2I, B=2I+1. Параметр I изменяется от 1 до 5.

(Оператор цикла с параметром)

4) Вычислить A=2I, B=2I+2. Параметр цикла I изменяется от 5 до 1.

(Оператор цикла с параметром)

5) Составить программу, которая выводит автоматически квадраты целых чисел от 1 до 10.

(Оператор цикла с предусловием)

6) Вычислить Y=X3, где Х изменяется от 1 до 10

(Оператор цикла с послеусловием).

7) Вычислить выражения Y= X2+1, Z=, Х от 1 до 10.

(Оператор цикла с параметром)

8) Составить программу, которая выводит квадраты вводимых чисел во время выполнения программы до тех пор, пока введенное число не станет больше либо равно 10. (Оператор цикла с предусловием)

9) Составить программу для вычисления суммы квадратов чисел от 1, 2, 3, …, 15.

(Оператор цикла с параметром)

10) Составить программу, которая выводит на экран таблицу умножения от 2 до 9. (Сложные циклы)

11) Составить программу, которая выводит на экран таблицу умножения для вводимых в произвольной форме чисел от 1 до 10. (Сложные циклы)



Вы находитесь на странице вопроса "Проверочная работа &lt;Линейные алгоритмы&gt; Вариант 2 Составить программы для вычисления: a) Полусуммы кубов", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.