Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Программа должна быть написана в среде Pascal.

10-11 класс

Ввести 20 строчек английским языком большими буквами. Определить какие буквы присутствовали в данных предложениях, какая буква встречалась больше раз и напечатать их. В массиве делаем, пожалуйста.

Анюточка111 20 мая 2014 г., 13:00:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alex20025458
20 мая 2014 г., 15:26:45 (9 лет назад)

Program Task;
Const A = 65; Z = 90; N = 20;
Var b: Array[A..Z] of Integer;
i, j, max: Byte;
s: Array[1..N] of String;
Begin
WriteLn('Введите ', N, ' строчек большими буквами на английском языке');
For i := 1 To N Do
ReadLn(s[i]);
For i := 1 To N Do
For j := 1 To Length(s[N]) Do
If (Ord(s[i][j]) >= A) And (Ord(s[i][j]) <= Z) Then
b[Ord(s[i][j])] := b[Ord(s[i][j])] + 1;
max := A;
WriteLn('В данных предложениях присутствовали такие буквы:');
For i := A To Z Do
Begin
If b[i] > 0 Then
Begin
Write(Chr(i), ' ');
If b[i] > b[max] Then
max := i;
End;
End;
WriteLn;
WriteLn('Наиболее встречалась буква ', chr(max));
ReadLn;
End.

Ответить

Другие вопросы из категории

постройте модель следующего процесса соблюдая основные этапы моделирования Гражданин Петров взял в долг у своего приятеля

Сидорова 9800р.выдав последнему вексель,по которому обязался выплатить 10 000р. через 3 месяца, Под какой долговой процент выдан вексель?помогите

Читайте также

Всем привет, помогите написать программу в паскале, смысл прост. Программа должна переводить число из шестнадцатиричной системы счисления в дестяричную и

наоборот, тоесть после вводе числа- FFF программа должна вывести число 4095 и ниже снова FFF, программа должна быть простая и не слишком умная. Заранее спасибо

Написать подпрограмму, вычисляющую натуральную степень

числа. паскаль
написать программу на компьютере и проверить правильность
работы Вашей процедуры/функции, в этом случае в основной программе
должны быть реализованы ввод исходных данных и вызов
процедуры/функции.

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

Pascal (Паскаль). Очень прошу помощи

Составить программу сортировки массива методом пузырька НО не использовать for
Только через repeat + использовать flag
Всего в программе должно быть 3 переменных:

ПАСКАЛЬ АВС

ОЧЕНЬ СРОЧНО,ПОЖАЛУЙСТА


При помощи функции trunc() в Паскале можно реализовать операции целочисленного деления и взятия остатка от деления. Например:
целочисленное деление - trunc(491/240) - результатом будет 2;
остаток от деления - 491-240*trunc(491/240) - результатом будет 11.
Используя функцию trunc(), напишите программу, считающую сдачу в английской денежной системе (в этой денежной системе 1 фунт стерлингов равен 20 шиллингам, а 1 шиллинг равен 12 пенсам). Напишите программу, в которой в трёх константах хранится стоимость товара. Одна константа - фунты (целое значение больше нуля), вторая - шиллинги (значение от 0 до 19), третья - пенсы (значение от 0 до 11). Ещё в трёх таких же константах хранится плата покупателя. Используя одну целочисленную переменную, программа должна сосчитать и вывести на экран сдачу в фунтах, шиллингах и пенсах. НЕ ИСПОЛЬЗОВАТЬ УСЛОВНЫЙ ОПЕРАТОР

ПРОГРАММА ДОЛЖНА БЫТЬ НАПИСАНА НА ПАСКАЛЕ АВС



Вы находитесь на странице вопроса "Программа должна быть написана в среде Pascal.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.