Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать подпрограмму, вычисляющую натуральную степень

10-11 класс

числа. паскаль
написать программу на компьютере и проверить правильность
работы Вашей процедуры/функции, в этом случае в основной программе
должны быть реализованы ввод исходных данных и вызов
процедуры/функции.

Gavrilovayul 15 мая 2014 г., 6:08:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
поночка
15 мая 2014 г., 6:44:23 (9 лет назад)

Используем достаточно хорошо известный "индийский алгоритм" возведения в степень. Я не буду здесь его приводить из-за достаточно большого объема сопровождающих рассуждений; все легко находится в Интернет по фразе "индийский алгоритм возведения в степень".

function Power(x: double; n: integer): double;
var
  p: double;
  flag: boolean;
begin
  p := 1; flag := true;
  while flag do
  begin
    if odd(n) then p := p * x;
    n := n div 2;
    if n > 0 then x := x * x else flag := false
  end;
  power := p
end;

var
  x: double;
  n: integer;

begin
  Writeln('Введите число и натуральную степень, в которую его надо возвести');
  Readln(x, n);
  Writeln('Результат: ', Power(x, n))
end.

Тестовое решение:
Введите число и натуральную степень, в которую его надо возвести
3.6 11
Результат: 1316217.03842267

Точный результат равен 1316217.03842267136.



Ответить

Читайте также

1. написать программу, вычисляющую значение функции y=x-24

2. написать программу, вычисляющую значение функции (y=f(x))
y=x-2, если x>0,
y=0, если x=0,
y=x*x, если x<0

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.

PASAL

написать программу вычисляющую произведение второй и четвертой цифр четырехзначного числа.



Вы находитесь на странице вопроса "Написать подпрограмму, вычисляющую натуральную степень", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.