Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дана строка. среди символов встречаются цифры. написать программу, вычисляющую сумму всех цифр

10-11 класс

Emofer 13 дек. 2013 г., 20:17:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MeLoDy2002
13 дек. 2013 г., 21:40:40 (10 лет назад)

var
  digits: set of '0'..'9';
  s: string;
  i, p, d, err: integer;

begin
  digits := ['0'..'9'];
  Write('Введите строку: '); Readln(s);
  p := 0;
  for i := 1 to Length(s) do
    if (s[i] in digits) then
    begin Val(s[i], d, err); p := p + d end;
  Writeln('Сумма цифр равна ', p)
end.

Тестовое решение:
Введите строку: Сегодня 17 декабря 2014г. Находим сумму 7 цифр их этой строки.
Сумма цифр равна 22


Ответить

Другие вопросы из категории

срочно, помогите пожалуйста..
Очень вас прошу помочь написать программу.Написать программу-

1)с помощью генератора случайных чисел создать Н числа в диапазоне с [-50;50](длину массива Н надо ввести с клавиатуры)
2)надо вывести сделанный массив на экран
3)нужно вычислить и вывести,какое количество парных чисел
4)и вывести на экран все парные числа.
Очень вас прошу помогите,очень нужно до завтра сделать.Если можете помочь мне,пожалуйста помогите.

Читайте также

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

1. написать программу, вычисляющую значение функции y=x-24

2. написать программу, вычисляющую значение функции (y=f(x))
y=x-2, если x>0,
y=0, если x=0,
y=x*x, если x<0

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива



Вы находитесь на странице вопроса "дана строка. среди символов встречаются цифры. написать программу, вычисляющую сумму всех цифр", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.