Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана строка. Среди символов строки встречаются цифры. Написать программу, вычисляющую сумму всех цифр строки.

10-11 класс

Tolebiaman 28 мая 2013 г., 14:32:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Chocolate1488
28 мая 2013 г., 16:41:36 (10 лет назад)

Pascal
---
var s:string;  
     i,c,sum:integer;
begin
    readln(s);
    sum:= 0;
    for i:=1 to Length(s) do
        if (s[i]>='0')and(s[i]<='9') then
        begin
           c:=ord(s[i])-48;
           sum:=sum+c;
        end;
    writeln(sum);
end.

+ 0 -
Chingizhan1998
28 мая 2013 г., 19:37:15 (10 лет назад)

почему практически никто не пишет, в какой среде нужна программа?

Ответить

Другие вопросы из категории

1 кАКОЙ ОБЪЕМ ВИДЕОПАМЯТИ В КИЛОБАЙТАХ НУЖЕН ДЛЯ ХРАНЕНИЯ ИЗОБРАЖЕНИЯ РАЗМЕРОМ 600Х350 ПИКСЕЛЕЙ, ИСПОЛЬЗУЮЩЕГО 8 ЦВЕТНУЮ ПАЛИТРУ. 2

>Зеленый цвет на компьютере с объемом страницы видеопамяти 125 Кбайт кодируется кодом 0010. Какова может быть разрешающая способность монитора?

Ребят если можно с полным решением.))))

паскаль написать программу Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если сумма

первых двух чисел четна, то выведите эту сумму. Если сумма третьего и четвертого чисел четна и отрицательна, то выведите все четыре числа без изменения. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих четырех чисел. Иначе, выведите суммы двух первых и двух последних чисел.

когда появились первые ЭВМ ?
Помогите с блок схемой!!пожалуйста(((

program lab;
uses crt;
const nmax=20;
var a:array[1..nmax,1..nmax] of integer;
x:integer;
n,m,i,j,p,q,k:byte;
begin
writeln('Поиск неповторяющихся элементов двухмерного массива целых чисел');writeln;
randomize;
repeat
write('Введите количество строк...');
read(m);
until m in [1..nmax];
repeat
write('Введите количество столбцов...');
read(n);
write('Введите элементы двухмерного массива:');writeln;
until n in [1..nmax];
for i:=1 to m do
begin
for j:=1 to n do
begin
write(' [',i,',',j,']...');
readln(a[i,j]);

end;

end;
writeln('Исходная матрица:');

for i:=1 to m do
begin
for j:=1 to n do
begin

write(a[i,j]:4);
end;
writeln;
end;
writeln;
writeln('Неповторяющиеся элементы массива:');writeln;
for i:=1 to m do
for j:=1 to n do
begin
x:=a[i,j];
k:=0;
for p:=1 to m do
for q:=1 to n do
if a[p,q]=x then k:=k+1;
if k=1 then write(x,' ');
end;
end.

Читайте также

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

1. написать программу, вычисляющую значение функции y=x-24

2. написать программу, вычисляющую значение функции (y=f(x))
y=x-2, если x>0,
y=0, если x=0,
y=x*x, если x<0

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива



Вы находитесь на странице вопроса "Дана строка. Среди символов строки встречаются цифры. Написать программу, вычисляющую сумму всех цифр строки.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.