Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан линейный массив А[1..N], содержащий целые числа. Получить те элементы массива , которые являются полными квадратами.

5-9 класс

волчок55 08 сент. 2014 г., 4:29:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Кэролай3454646
08 сент. 2014 г., 7:17:14 (9 лет назад)

var

a:[1..100] array of integer;

i,n,p:integer;

begin

readln(n);

for i:=1 to n do

begin

readln(a[i]);

p:=2;

while (p*p<=a[i]) do

begin

if p*p=a[i] then writeln (a[i],' полный квадрат')

p:=p+1;

end;

end;

end.

Ответить

Читайте также

1. Указать ошибки в описании массива и пути их исправления: var a:array[real] of integer;

2. Определить,что распечатает следующая программа:
var a: array[1..5,1..5]of integer,i,j; integer;
begin
for i:=1 to 5 do begin
for j:=1 to 5 do begin
if i=5-j+1 then a[i,j]:=0
else a [i,j]:=0;
write(a[i,j]:2);
end;
writeln;
end; end.
3. Дан линейный массив a [l..n], содержащий целые числа. Вычислить сумму чисел делящихся одновременно на 5 и на 3 и распечатать номера таких чисел
4.Дан линейный массив a [l..n], содержащий целые числа. Преобразовать элементы массива по следующему правилу : если элемент положительный,то заменить его на 1, а если отрицательный - возвести в квадрат

PascalABC 40 баллов!!!

1) Дан линейный массив a[1..n], содержащий целые числа. Вычислите сумму нечетных чисел и распечатать номера таких чисел. 2) Дан линейных массив [1..n], содержащий целые числа. Преобразовать элементы массива по следующему правилу: если элемент положительный, то умножить его на два, а если отрицательный -- поменять знак на противоположный.

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.



Вы находитесь на странице вопроса "Дан линейный массив А[1..N], содержащий целые числа. Получить те элементы массива , которые являются полными квадратами.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.